summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pms')
-rw-r--r--media-sound/pms/Manifest1
-rw-r--r--media-sound/pms/metadata.xml13
-rw-r--r--media-sound/pms/pms-0.42-r1.ebuild45
-rw-r--r--media-sound/pms/pms-0.42.ebuild45
-rw-r--r--media-sound/pms/pms-9999.ebuild47
5 files changed, 151 insertions, 0 deletions
diff --git a/media-sound/pms/Manifest b/media-sound/pms/Manifest
new file mode 100644
index 000000000000..0517e1b6fa74
--- /dev/null
+++ b/media-sound/pms/Manifest
@@ -0,0 +1 @@
+DIST pms-0.42.tar.bz2 196053 SHA256 96bf942b08cba10ee891a63eeccad307fd082ef3bd20be879f189e1959e775a6 SHA512 34fea13f524154455d9a44eb5c885ae3a555adc5e495234c0e720c7351b0e9169226cede08b65eb8236d6b0f35eaeae4968baa374dfd4f53c6cc164cb669ab0a WHIRLPOOL 45a0bb0322541cad6dffb14bb28c1156ce85be7ced57cc7a8dcc12d6b3f298d811f564b522d0110eeceb9fe697bf402541384d611b94fb211bda2181e68b1d1f
diff --git a/media-sound/pms/metadata.xml b/media-sound/pms/metadata.xml
new file mode 100644
index 000000000000..67d53893f383
--- /dev/null
+++ b/media-sound/pms/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>wired@gentoo.org</email>
+ <name>Alex Alexander</name>
+ </maintainer>
+ <use>
+ <flag name='regex'>Enable regular expression searches
+ using <pkg>dev-libs/boost</pkg></flag>
+ </use>
+</pkgmetadata>
+
diff --git a/media-sound/pms/pms-0.42-r1.ebuild b/media-sound/pms/pms-0.42-r1.ebuild
new file mode 100644
index 000000000000..67e01f4b75c1
--- /dev/null
+++ b/media-sound/pms/pms-0.42-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="http://pms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses
+ dev-libs/glib:2
+ regex? ( dev-libs/boost:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # bug #424717
+ sed -i -e "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die 'sed on Makefile.am failed'
+
+ # Compatibility with automake 1.14
+ sed -i -e '/AM_INIT_AUTOMAKE/s/-Werror/subdir-objects/' configure.ac || die 'sed on configure.ac failed'
+
+ epatch_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable regex)
+}
diff --git a/media-sound/pms/pms-0.42.ebuild b/media-sound/pms/pms-0.42.ebuild
new file mode 100644
index 000000000000..a6d0e145873b
--- /dev/null
+++ b/media-sound/pms/pms-0.42.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="http://pms.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses
+ dev-libs/glib:2
+ regex? ( >=dev-libs/boost-1.36 )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ # bug #424717
+ sed -i "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable regex) ||
+ die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+
+ dodoc AUTHORS README TODO
+}
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
new file mode 100644
index 000000000000..7ead914d10b8
--- /dev/null
+++ b/media-sound/pms/pms-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools git-2
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="http://pms.sourceforge.net/"
+SRC_URI=""
+
+EGIT_REPO_URI="git://pms.git.sourceforge.net/gitroot/pms/pms"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses
+ dev-libs/glib:2
+ regex? ( >=dev-libs/boost-1.36 )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ # bug #424717
+ sed -i "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable regex) ||
+ die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+
+ dodoc AUTHORS README TODO
+}