summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pms/pms-9999.ebuild')
-rw-r--r--media-sound/pms/pms-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
new file mode 100644
index 000000000000..7ead914d10b8
--- /dev/null
+++ b/media-sound/pms/pms-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools git-2
+
+DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
+HOMEPAGE="http://pms.sourceforge.net/"
+SRC_URI=""
+
+EGIT_REPO_URI="git://pms.git.sourceforge.net/gitroot/pms/pms"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="regex"
+
+RDEPEND="
+ sys-libs/ncurses
+ dev-libs/glib:2
+ regex? ( >=dev-libs/boost-1.36 )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ # bug #424717
+ sed -i "s:^CXXFLAGS +=:AM_CXXFLAGS =:g" Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable regex) ||
+ die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+
+ dodoc AUTHORS README TODO
+}