summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-13 13:24:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-13 16:07:05 +0200
commit53bae14e5a90498278474bb6d305beb09d3bdbfa (patch)
treeac7207b99f98abf44fdbfbfa77b80a6399a525e1 /dev-ros/rosgraph/rosgraph-1.15.4.ebuild
parentdev-ros/rosbag_storage: Bump to 1.15.4. (diff)
downloadgentoo-53bae14e5a90498278474bb6d305beb09d3bdbfa.tar.gz
gentoo-53bae14e5a90498278474bb6d305beb09d3bdbfa.tar.bz2
gentoo-53bae14e5a90498278474bb6d305beb09d3bdbfa.zip
dev-ros/rosgraph: Bump to 1.15.4.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.15.4.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.15.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.15.4.ebuild b/dev-ros/rosgraph/rosgraph-1.15.4.ebuild
new file mode 100644
index 000000000000..49cca14bf4f3
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.15.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"