summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-17 05:16:12 +0100
committerSam James <sam@gentoo.org>2024-07-17 05:16:30 +0100
commit36c44443c4e698841c7b5044470ef13b9c99dd7f (patch)
treeb99a431f0641fe23786e5943ca7d229966c4731b /dev-debug
parentdev-debug/cgdb: drop 0.7.1 (diff)
downloadgentoo-36c44443c4e698841c7b5044470ef13b9c99dd7f.tar.gz
gentoo-36c44443c4e698841c7b5044470ef13b9c99dd7f.tar.bz2
gentoo-36c44443c4e698841c7b5044470ef13b9c99dd7f.zip
dev-debug/cgdb: fix modern C issue in configure
No need for a revbump here as it failed to compile if the check failed, not misdetecting anything. Closes: https://bugs.gentoo.org/830222 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/cgdb/cgdb-0.8.0.ebuild24
-rw-r--r--dev-debug/cgdb/files/cgdb-0.8.0-configure-c99.patch23
2 files changed, 37 insertions, 10 deletions
diff --git a/dev-debug/cgdb/cgdb-0.8.0.ebuild b/dev-debug/cgdb/cgdb-0.8.0.ebuild
index fad641ffce59..4c8395ac8b3f 100644
--- a/dev-debug/cgdb/cgdb-0.8.0.ebuild
+++ b/dev-debug/cgdb/cgdb-0.8.0.ebuild
@@ -24,23 +24,26 @@ IUSE="test"
RESTRICT="test"
DEPEND="
- sys-libs/ncurses:0=
- sys-libs/readline:0="
-
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+"
BDEPEND="
+ sys-devel/flex
test? (
dev-util/dejagnu
app-misc/dtach
- )"
-
+ )
+"
RDEPEND="
${DEPEND}
- dev-debug/gdb"
+ dev-debug/gdb
+"
DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
PATCHES=(
"${FILESDIR}"/${P}-ar.patch
+ "${FILESDIR}"/${PN}-0.8.0-configure-c99.patch
)
src_prepare() {
@@ -48,6 +51,11 @@ src_prepare() {
AT_M4DIR="config" eautoreconf
}
+multilib_src_configure() {
+ unset LEX
+ ECONF_SOURCE="${S}" econf
+}
+
multilib_src_test() {
# Tests need an interactive shell, #654986
@@ -63,7 +71,3 @@ multilib_src_test() {
[[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
[[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf
-}
diff --git a/dev-debug/cgdb/files/cgdb-0.8.0-configure-c99.patch b/dev-debug/cgdb/files/cgdb-0.8.0-configure-c99.patch
new file mode 100644
index 000000000000..bd021476bf53
--- /dev/null
+++ b/dev-debug/cgdb/files/cgdb-0.8.0-configure-c99.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/830222
+https://github.com/cgdb/cgdb/pull/338
+
+From 039dba0ec3ae2c4b2636418652a5c63f9ff86049 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Wed, 8 Mar 2023 11:29:06 +0100
+Subject: [PATCH] configure: Avoid implicit int in readline check
+
+Future compilers will not accept implicit ints by default, altering
+the outcome of the check without this change.
+
+Signed-off-by: Florian Weimer <fweimer@redhat.com>
+--- a/config/readline_check_version.m4
++++ b/config/readline_check_version.m4
+@@ -86,7 +86,7 @@ AC_CACHE_VAL(ac_cv_rl_version,
+ #include <stdlib.h>
+ #include <readline/readline.h>
+
+-main()
++int main(void)
+ {
+ FILE *fp;
+ fp = fopen("conftest.rlv", "w");