summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-17 05:12:22 +0100
committerSam James <sam@gentoo.org>2024-07-17 05:16:30 +0100
commitd9f576f130f686a10cf92e800203b20cc1edb573 (patch)
treecbe3319b1450a6d809f95ed0d5283f0c950ecd67 /dev-debug
parentdev-python/croniter: Bump to 2.0.7 (diff)
downloadgentoo-d9f576f130f686a10cf92e800203b20cc1edb573.tar.gz
gentoo-d9f576f130f686a10cf92e800203b20cc1edb573.tar.bz2
gentoo-d9f576f130f686a10cf92e800203b20cc1edb573.zip
dev-debug/cgdb: drop 0.7.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/cgdb/Manifest1
-rw-r--r--dev-debug/cgdb/cgdb-0.7.1.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-debug/cgdb/Manifest b/dev-debug/cgdb/Manifest
index 38abca18f809..772ad27a5505 100644
--- a/dev-debug/cgdb/Manifest
+++ b/dev-debug/cgdb/Manifest
@@ -1,2 +1 @@
-DIST cgdb-0.7.1.tar.gz 314768 BLAKE2B 767a57d071fa4e3c75d231a1ec879d871669fcda9c733d157d380fa525dd321f1deb68d7ef7f424b3f36a115043a0a0faae271f24746f934e288ba7d9a4e7fa1 SHA512 050c7bad963d51c1a2cb309530319ca77e9d236f419fb0abac4ab5030ff1068d799fa626959a8b3036321711de98bddf40d264bf9367ff5697075e30ca8168c6
DIST cgdb-0.8.0.tar.gz 328281 BLAKE2B 60e577dd5f8363b91da33136a9ffd911581e9cea4cdc1d0fcd338e0a761a26921e6edf6298c619b8d0eb1486449843457b2c5370a395a8c49fed5382a60e63a2 SHA512 e2b653db472de2014402dae6d13953ab811526a47ad5d7a05e34cfba09f44d6fea6b19304b9205ff0e2ac9549ffa5818f4282d7c03293b6c0ca9d563f9ae89e1
diff --git a/dev-debug/cgdb/cgdb-0.7.1.ebuild b/dev-debug/cgdb/cgdb-0.7.1.ebuild
deleted file mode 100644
index 970c6382192f..000000000000
--- a/dev-debug/cgdb/cgdb-0.7.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="
- https://github.com/cgdb/cgdb.git
- git@github.com:cgdb/cgdb.git"
-else
- SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-fi
-
-inherit autotools multilib-minimal
-
-DESCRIPTION="A curses front-end for GDB, the GNU debugger"
-HOMEPAGE="https://cgdb.github.io/"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- sys-libs/ncurses:0=
- sys-libs/readline:0="
-
-BDEPEND="
- test? (
- dev-util/dejagnu
- app-misc/dtach
- )"
-
-RDEPEND="
- ${DEPEND}
- dev-debug/gdb"
-
-DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
-
-PATCHES=(
- # Bugs: #730138, #678006, #630512
- "${FILESDIR}/${PN}-test.patch"
- # Bug: #724256
- "${FILESDIR}/${P}-respect-AR.patch"
-)
-
-src_prepare() {
- default
- cp configure.{init,ac} || die "cp failed"
- AT_M4DIR="config" eautoreconf
-}
-
-multilib_src_test() {
- # Tests need an interactive shell, #654986
-
- # real-time output of the log ;-)
- touch "${T}/dtach-test.log" || die
- tail -f "${T}/dtach-test.log" &
- local tail_pid=${!}
-
- nonfatal dtach -N "${T}/dtach.sock" \
- bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
-
- kill "${tail_pid}"
- [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
- [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf
-}