summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-16 19:14:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-16 19:14:33 +0200
commitd1a8378613b3586a3f6787047c1238b648d5e84a (patch)
tree453c6588916c11742efe7d8cabed1ec1195cf371 /app-arch/bzip3
parentnet-libs/ngtcp2: 0.5.0 version bump (diff)
downloadgentoo-d1a8378613b3586a3f6787047c1238b648d5e84a.tar.gz
gentoo-d1a8378613b3586a3f6787047c1238b648d5e84a.tar.bz2
gentoo-d1a8378613b3586a3f6787047c1238b648d5e84a.zip
app-arch/bzip3: bump to 1.1.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.1.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index 6e224d59c754..74a9f9ed885c 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1,2 +1,3 @@
DIST bzip3-1.1.1.tar.gz 2349860 BLAKE2B dd740b631b66db40bce35cccc0a46e4bbfe2a929aeaa2b083419e94cfcf3967c97fc6233e50fb1b0cb185ebd23bcad082567ca11ad5f0f037bdc4a95eb792f77 SHA512 22c7e415b2cd423b08a99051fd54bf0773e11a978559c9c382a4667087d6f1671de9ec564a5badbe1e8283aba83f5d1c70392ba7a0a96c8669ffee302d5d47e9
DIST bzip3-1.1.2.tar.xz 256108 BLAKE2B a5f91fe2760fd4f7f79b908d735d613823dedac23e59950317c26f50d0a657dde042e5a08d401984c14d686d33726caa81e4b34cbca26e28c57a96f61e4f23ab SHA512 8b179bfe9b1b67c516580934cd12a640c86b3f9525c5e7902672051d80198cb91aa8880a4ca3ce14a879d26873405c713f1a0c6a33138d21f4d51c9e93d8fac5
+DIST bzip3-1.1.3.tar.xz 257212 BLAKE2B cc94b4c2caa3123b2c775d66143757bcaea7ead6d8a130391d6714583cfcb92fffca47ad80ffc8b5a01483f6cbfab7101c96521cd97e740116c9e10c64c358e8 SHA512 d48695d066ddc79e81c189f8c06e999f8eb8191982db8908f7bd4dfaa0f8fab1ba57e41664962cc6e8611f8398603918e4bd4d58efff2f04292ea54983a6f38d
diff --git a/app-arch/bzip3/bzip3-1.1.3.ebuild b/app-arch/bzip3/bzip3-1.1.3.ebuild
new file mode 100644
index 000000000000..bc68102070ae
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs autotools
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf $(use_enable static-libs static) CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}