aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2022-04-06 19:44:20 +0200
committerDuje Mihanović <duje.mihanovic@skole.hr>2022-04-06 19:44:20 +0200
commitecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b (patch)
tree330e182e96dc2b5b8bbd549bab43948b61f457c3 /sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild
parentdev-python/retworkx: fix CFLAGS/LDFLAGS QA notice (diff)
downloadguru-ecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b.tar.gz
guru-ecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b.tar.bz2
guru-ecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b.zip
sys-auth/pam-gnupg: initial import
Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr>
Diffstat (limited to 'sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild')
-rw-r--r--sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild b/sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild
new file mode 100644
index 000000000..2d892a1c1
--- /dev/null
+++ b/sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Unlock GnuPG keys on login"
+HOMEPAGE="https://github.com/cruegge/pam-gnupg"
+SRC_URI="https://github.com/cruegge/pam-gnupg/archive/refs/tags/v${PV}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+>=sys-libs/pam-1.5.1_p20210622-r1
+>=app-crypt/gnupg-2.2.33-r1
+"
+
+src_configure() {
+ eautoreconf
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --with-moduledir=/$(get_libdir)/security \
+ --mandir=/usr/share/man || die
+}