aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2022-04-06 19:44:20 +0200
committerDuje Mihanović <duje.mihanovic@skole.hr>2022-04-06 19:44:20 +0200
commitecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b (patch)
tree330e182e96dc2b5b8bbd549bab43948b61f457c3 /sys-auth
parentdev-python/retworkx: fix CFLAGS/LDFLAGS QA notice (diff)
downloadguru-ecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b.tar.gz
guru-ecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b.tar.bz2
guru-ecd9dc50a8ea3707924eb946d7e6d3a1a4d67b4b.zip
sys-auth/pam-gnupg: initial import
Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam-gnupg/Manifest1
-rw-r--r--sys-auth/pam-gnupg/metadata.xml8
-rw-r--r--sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild27
3 files changed, 36 insertions, 0 deletions
diff --git a/sys-auth/pam-gnupg/Manifest b/sys-auth/pam-gnupg/Manifest
new file mode 100644
index 000000000..cb4d9fd28
--- /dev/null
+++ b/sys-auth/pam-gnupg/Manifest
@@ -0,0 +1 @@
+DIST v0.3.tar.gz 20827 BLAKE2B 3973ffceec48105c28f368c14c879f9c1cae1676a5f5134c49249b3db8877418c2e9ac7937a6cacb3c5c2089be9a6e03c96e1988ecb029756c2f404674b9126c SHA512 5ee9af0f2e0d32680d6bc5e5b55ce46b86f01ff47b364a34484a6522035c96b8556c65d3d834ff711fb158ec4f1edbd48a1fea883641dedcbebd40074dc2fc5f
diff --git a/sys-auth/pam-gnupg/metadata.xml b/sys-auth/pam-gnupg/metadata.xml
new file mode 100644
index 000000000..62988a0d4
--- /dev/null
+++ b/sys-auth/pam-gnupg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>duje.mihanovic@skole.hr</email>
+ <name>Duje Mihanović</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild b/sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild
new file mode 100644
index 000000000..2d892a1c1
--- /dev/null
+++ b/sys-auth/pam-gnupg/pam-gnupg-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Unlock GnuPG keys on login"
+HOMEPAGE="https://github.com/cruegge/pam-gnupg"
+SRC_URI="https://github.com/cruegge/pam-gnupg/archive/refs/tags/v${PV}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+RDEPEND="
+>=sys-libs/pam-1.5.1_p20210622-r1
+>=app-crypt/gnupg-2.2.33-r1
+"
+
+src_configure() {
+ eautoreconf
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --with-moduledir=/$(get_libdir)/security \
+ --mandir=/usr/share/man || die
+}