summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-01 07:42:08 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-01 07:42:08 +0000
commitf982bb01d2d2bd662f07b32dd47fed0e9bc0fb1e (patch)
tree31b79c24a49d8b22aa0d66b36529442c21d5204e /net-misc/e1000/e1000-5.2.30.1.ebuild
parentVersion bumped. Closes 43232 (diff)
downloadhistorical-f982bb01d2d2bd662f07b32dd47fed0e9bc0fb1e.tar.gz
historical-f982bb01d2d2bd662f07b32dd47fed0e9bc0fb1e.tar.bz2
historical-f982bb01d2d2bd662f07b32dd47fed0e9bc0fb1e.zip
improved low-end switches compatiblity.
Diffstat (limited to 'net-misc/e1000/e1000-5.2.30.1.ebuild')
-rw-r--r--net-misc/e1000/e1000-5.2.30.1.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/net-misc/e1000/e1000-5.2.30.1.ebuild b/net-misc/e1000/e1000-5.2.30.1.ebuild
index f043f2e90ce5..b035dd32767a 100644
--- a/net-misc/e1000/e1000-5.2.30.1.ebuild
+++ b/net-misc/e1000/e1000-5.2.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.1 2004/02/03 12:15:07 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.2 2004/03/01 07:42:08 mholzer Exp $
DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
@@ -26,7 +26,14 @@ src_unpack() {
src_compile() {
check_KV
cd "${S}/src"
- make KSRC=/usr/src/linux clean e1000.o
+
+ # workaround needed for some ethernet controllers to work with low end switches
+ if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+ then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+ else CFLAGS_EXTRA=""
+ fi
+
+ make ${CFLAGS_EXTRA} KSRC=/usr/src/linux clean e1000.o
}
@@ -34,8 +41,11 @@ src_install() {
insinto "/lib/modules/${KV}/kernel/drivers/net"
doins "${S}/src/e1000.o"
doman e1000.7
- dodoc LICENSE README SUMS e1000.spec ldistrib.txt
+ dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
einfo ""
einfo "In case you have problems, loading the module, try to run depmod -A"
einfo ""
+ einfo "If you experience problems with low-end switches, read"
+ einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
+ einfo ""
}