summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/e1000/ChangeLog7
-rw-r--r--net-misc/e1000/Manifest9
-rw-r--r--net-misc/e1000/e1000-5.2.30.1.ebuild16
-rw-r--r--net-misc/e1000/files/README.Gentoo28
4 files changed, 52 insertions, 8 deletions
diff --git a/net-misc/e1000/ChangeLog b/net-misc/e1000/ChangeLog
index 2054eeb2507a..ff61617ebcdf 100644
--- a/net-misc/e1000/ChangeLog
+++ b/net-misc/e1000/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/e1000
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/ChangeLog,v 1.13 2004/02/03 12:15:07 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/ChangeLog,v 1.14 2004/03/01 07:42:08 mholzer Exp $
+
+ 01 Mar 2004; Martin Holzer <mholzer@gentoo.org> e1000-5.2.30.1.ebuild,
+ files/README.Gentoo:
+ improved low-end switches compatiblity. Submitted by
+ Dennis Nienhüser <fragfred@gmx.de> in 43306.
*e1000-5.2.30.1 (03 Feb 2004)
diff --git a/net-misc/e1000/Manifest b/net-misc/e1000/Manifest
index 4914742a07ac..1dd1c6b193b6 100644
--- a/net-misc/e1000/Manifest
+++ b/net-misc/e1000/Manifest
@@ -1,7 +1,8 @@
-MD5 8a783e2f93c16c4077d2cfddc1dda1cf ChangeLog 1707
-MD5 c2788433f30fe41e4c834856cc469e93 e1000-5.2.20.ebuild 1066
MD5 685cab07fee48c1ac7c2a6ede5ffa32e e1000-5.2.22.ebuild 1067
-MD5 ab36aa4046c7ad0f60d7349d9acbb132 e1000-5.2.30.1.ebuild 1069
+MD5 c2788433f30fe41e4c834856cc469e93 e1000-5.2.20.ebuild 1066
+MD5 8360054a21c364fd832a05fc21949145 e1000-5.2.30.1.ebuild 1464
+MD5 1b187fb99d7d97ff232631cdb842bd0b ChangeLog 1907
+MD5 77270d006917b099ca5e4684c80abf0f files/digest-e1000-5.2.30.1 66
+MD5 0b6de6b5497b7f4ed7f2469565a3e28e files/README.Gentoo 1002
MD5 5a0d0eea9a3155b09fb3177c6f646d8b files/digest-e1000-5.2.20 64
MD5 48bc3d8e4999566aa077df43475f4854 files/digest-e1000-5.2.22 64
-MD5 77270d006917b099ca5e4684c80abf0f files/digest-e1000-5.2.30.1 66
diff --git a/net-misc/e1000/e1000-5.2.30.1.ebuild b/net-misc/e1000/e1000-5.2.30.1.ebuild
index f043f2e90ce5..b035dd32767a 100644
--- a/net-misc/e1000/e1000-5.2.30.1.ebuild
+++ b/net-misc/e1000/e1000-5.2.30.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.1 2004/02/03 12:15:07 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/e1000/e1000-5.2.30.1.ebuild,v 1.2 2004/03/01 07:42:08 mholzer Exp $
DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
@@ -26,7 +26,14 @@ src_unpack() {
src_compile() {
check_KV
cd "${S}/src"
- make KSRC=/usr/src/linux clean e1000.o
+
+ # workaround needed for some ethernet controllers to work with low end switches
+ if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
+ then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
+ else CFLAGS_EXTRA=""
+ fi
+
+ make ${CFLAGS_EXTRA} KSRC=/usr/src/linux clean e1000.o
}
@@ -34,8 +41,11 @@ src_install() {
insinto "/lib/modules/${KV}/kernel/drivers/net"
doins "${S}/src/e1000.o"
doman e1000.7
- dodoc LICENSE README SUMS e1000.spec ldistrib.txt
+ dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
einfo ""
einfo "In case you have problems, loading the module, try to run depmod -A"
einfo ""
+ einfo "If you experience problems with low-end switches, read"
+ einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
+ einfo ""
}
diff --git a/net-misc/e1000/files/README.Gentoo b/net-misc/e1000/files/README.Gentoo
new file mode 100644
index 000000000000..91cfb1b9a115
--- /dev/null
+++ b/net-misc/e1000/files/README.Gentoo
@@ -0,0 +1,28 @@
+Workaround for some cards and low end switches
+==============================================
+
+There is a known problem with some cards and low-end switches where the
+ethernet controller is not able to establish a link (see README). In case
+you are experiencing this problem, try the following:
+
+# Stop networking for e1000
+$ /etc/init.d/net.eth0 stop
+$ rmmod e1000
+
+# compile e1000 with workaround
+$ USE_INCOMPATIBLE_SWITCH="yes" emerge e1000
+
+# load e1000 with parameters limiting its speed
+$ echo "alias eth0 e1000" > /etc/modules.d/e1000
+$ echo "options e1000 Speed=10 Duplex=2,1" >> /etc/modules.d/e1000
+$ update-modules
+
+# Start networking again
+$ modprobe e1000
+$ /etc/init.d/net.eth0 start
+
+This assumes /etc/conf.d/net is set up correctly and your kernel is
+configured without support for e1000 (neither as module nor compiled in)
+as it is needed for net-misc/e1000 to work.
+eth0 has to be replaced with the adapter you are using. You might need
+different settings for Speed and Duplex.