aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-03-26 15:54:51 +0100
committerDonnie Berkholz <dberkholz@gentoo.org>2009-03-26 15:54:51 +0100
commit258022b32783d6cfea6a6e90db9fc53e34223e5f (patch)
treed94b5b382ed0fa98c7af06436468102f1dea03ff /sci-libs
parentbigdft, etsf_io: Simplify compiler-flag setup. (diff)
downloaddberkholz-258022b32783d6cfea6a6e90db9fc53e34223e5f.tar.gz
dberkholz-258022b32783d6cfea6a6e90db9fc53e34223e5f.tar.bz2
dberkholz-258022b32783d6cfea6a6e90db9fc53e34223e5f.zip
libxc: Simplify compiler-flag setup. Drop src_test().
Upstream advises that src_test is impossible to analyze in an automated fashion.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libxc/Manifest2
-rw-r--r--sci-libs/libxc/libxc-0.9.ebuild23
2 files changed, 8 insertions, 17 deletions
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
index 346a019..fc8bbaf 100644
--- a/sci-libs/libxc/Manifest
+++ b/sci-libs/libxc/Manifest
@@ -1,2 +1,2 @@
DIST libxc-0.9.tar.gz 794754 RMD160 11dce930ca933ab23f229feaf3482f9419dff0e8 SHA1 2c9f0c7a3ec2ab840e4db0c0fd462581cf98195c SHA256 ad6aeb1513a3f0de88427c13036f675fbda30f81df8ed39413c7a0e0858097a4
-EBUILD libxc-0.9.ebuild 1156 RMD160 5fdb3d9e2b4c1b63711c32b138b725bb2c91f7c0 SHA1 bbdb4a9e7ddf0836d817c8809193ed37cff4e931 SHA256 2bb85887b723dddcbffebfc71d3b492c198aece95ec5124a656406a5e0ccb190
+EBUILD libxc-0.9.ebuild 1174 RMD160 f454f21e7c54ea85722c501ecd53b250dac6500f SHA1 8a1d6ffdd672d0ee7aeb8707b35261f5d008932f SHA256 e8dafc41a4fb066b83e333c32d89f3d49382963d4abf3ff47c0f31e2e9d87560
diff --git a/sci-libs/libxc/libxc-0.9.ebuild b/sci-libs/libxc/libxc-0.9.ebuild
index c6319d5..06d9b5d 100644
--- a/sci-libs/libxc/libxc-0.9.ebuild
+++ b/sci-libs/libxc/libxc-0.9.ebuild
@@ -8,7 +8,7 @@ inherit fortran multilib
DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="fortran"
@@ -23,25 +23,15 @@ pkg_setup() {
}
src_configure() {
- if [[ -n ${FFLAGS} ]]; then
- FCFLAGS="${FFLAGS}"
- else
- FCFLAGS="-O2"
- einfo "Defaulting to ${FCFLAGS} for FFFLAGS"
- fi
-
econf \
"$(use_enable fortran)" \
- FCFLAGS="${FCFLAGS}"
+ FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}"
}
-src_test() {
- emake check || die
- pushd testsuite >/dev/null
- einfo "Anything in bold red is a problem"
- ./xc-run_testsuite
- popd >/dev/null
-}
+## Upstream recommends not running the test suite because it requires
+## human expert interpretation to determine whether output is an error or
+## expected under certain circumstances.
+# src_test() { :; }
src_install() {
emake DESTDIR="${D}" install || die
@@ -49,6 +39,7 @@ src_install() {
dodoc README ChangeLog AUTHORS || die
if use fortran; then
+ # argument for this: --with-moduledir from etsf_io/bigdft
insinto /usr/$(get_libdir)/finclude
pushd src >/dev/null
doins *.mod || die