aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libxc/libxc-0.9.ebuild')
-rw-r--r--sci-libs/libxc/libxc-0.9.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/sci-libs/libxc/libxc-0.9.ebuild b/sci-libs/libxc/libxc-0.9.ebuild
index c6319d5..06d9b5d 100644
--- a/sci-libs/libxc/libxc-0.9.ebuild
+++ b/sci-libs/libxc/libxc-0.9.ebuild
@@ -8,7 +8,7 @@ inherit fortran multilib
DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
HOMEPAGE="http://www.tddft.org/programs/octopus/wiki/index.php/Libxc"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="fortran"
@@ -23,25 +23,15 @@ pkg_setup() {
}
src_configure() {
- if [[ -n ${FFLAGS} ]]; then
- FCFLAGS="${FFLAGS}"
- else
- FCFLAGS="-O2"
- einfo "Defaulting to ${FCFLAGS} for FFFLAGS"
- fi
-
econf \
"$(use_enable fortran)" \
- FCFLAGS="${FCFLAGS}"
+ FCFLAGS="${FCFLAGS:- ${FFLAGS:- -O2}}"
}
-src_test() {
- emake check || die
- pushd testsuite >/dev/null
- einfo "Anything in bold red is a problem"
- ./xc-run_testsuite
- popd >/dev/null
-}
+## Upstream recommends not running the test suite because it requires
+## human expert interpretation to determine whether output is an error or
+## expected under certain circumstances.
+# src_test() { :; }
src_install() {
emake DESTDIR="${D}" install || die
@@ -49,6 +39,7 @@ src_install() {
dodoc README ChangeLog AUTHORS || die
if use fortran; then
+ # argument for this: --with-moduledir from etsf_io/bigdft
insinto /usr/$(get_libdir)/finclude
pushd src >/dev/null
doins *.mod || die