summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2010-09-09 09:54:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2010-09-09 09:54:32 +0000
commitf71fd73663d59ddf0a1d3eeea34ff2291d0fd180 (patch)
tree14b891ac8a934448931665473b371f1c40258fa9 /x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
parentRespect LDFLAGS. Bug #336261 (diff)
downloadgentoo-2-f71fd73663d59ddf0a1d3eeea34ff2291d0fd180.tar.gz
gentoo-2-f71fd73663d59ddf0a1d3eeea34ff2291d0fd180.tar.bz2
gentoo-2-f71fd73663d59ddf0a1d3eeea34ff2291d0fd180.zip
Patched Makefile to make it at least decent. Closes bug #336547.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/wmlaptop/wmlaptop-1.3.ebuild')
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.3.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
index 97681240dfe3..977590a065e7 100644
--- a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
+++ b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.7 2009/01/14 15:54:35 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.8 2010/09/09 09:54:32 s4t4n Exp $
+
+inherit eutils
IUSE=""
-MY_P=${P}
-S=${WORKDIR}/${MY_P}
+MY_P="${P}"
+S="${WORKDIR}/${MY_P}/src"
DESCRIPTION="Dockapp for laptop users"
SRC_URI="http://www.dockapps.org/download.php/id/474/${P}.tar.bz2"
@@ -24,20 +26,20 @@ KEYWORDS="~amd64 ~ppc x86"
src_unpack() {
unpack ${A}
+ cd "${S}"
- #Prevent automatic stripping of binaries. Closes bug #252109
- sed -i 's/install -c -o 0 -g 0 -s -m/install -c -o 0 -g 0 -m/' "${S}/src/Makefile"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
}
src_compile() {
- emake CFLAGS="${CFLAGS} -Wall" || die "Compilation failed"
+ emake || die "Compilation failed"
}
src_install() {
dodir /usr/bin
einstall INSTALLDIR="${D}/usr/bin" || die "Installation failed"
- dodoc AUTHORS README README.IT THANKS
+ dodoc ../AUTHORS ../README ../README.IT ../THANKS
insinto /usr/share/applications
doins "${FILESDIR}/${PN}.desktop"