summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmlaptop/ChangeLog8
-rw-r--r--x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch32
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.3.ebuild18
3 files changed, 48 insertions, 10 deletions
diff --git a/x11-plugins/wmlaptop/ChangeLog b/x11-plugins/wmlaptop/ChangeLog
index 9042f05fb43b..2f2cae7e7502 100644
--- a/x11-plugins/wmlaptop/ChangeLog
+++ b/x11-plugins/wmlaptop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmlaptop
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/ChangeLog,v 1.8 2009/01/14 15:54:35 s4t4n Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/ChangeLog,v 1.9 2010/09/09 09:54:32 s4t4n Exp $
+
+ 09 Sep 2010; Michele Noberasco <s4t4n@gentoo.org>; wmlaptop-1.3.ebuild,
+ +files/wmlaptop-1.3-Makefile.patch:
+ Patched Makefile to make it at least decent. Closes bug #336547.
14 Jan 2009; Michele Noberasco <s4t4n@gentoo.org>; wmlaptop-1.3.ebuild:
Prevent automatic stripping of binaries. Closes bug #252109.
diff --git a/x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch b/x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch
new file mode 100644
index 000000000000..ab1148ce117e
--- /dev/null
+++ b/x11-plugins/wmlaptop/files/wmlaptop-1.3-Makefile.patch
@@ -0,0 +1,32 @@
+--- /Makefile 2010-09-09 13:44:07.000000000 +0200
++++ /Makefile.new 2010-09-09 13:47:40.000000000 +0200
+@@ -1,14 +1,17 @@
+-
++LIBDIR = -L/usr/X11R6/lib
++LIBS = -lXpm -lXext -lX11
++OBJS = main.o init.o event.o draw.o battery.o cpu.o autoscript.o pixmap.o
++EXE = wmlaptop
+
+
+ .c.o:
+- $(CC) -c $< -o $*.o $(CFLAGS)
++ $(CC) $(CFLAGS) -c $< -o $*.o
+
+ all: $(EXE)
+
+ $(EXE): $(OBJS)
+ ./buildCounter
+- $(CC) -o $(EXE) $^ $(LIBDIR) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(EXE) $^ $(LIBDIR) $(LIBS)
+
+
+ clean:
+@@ -20,7 +23,7 @@
+ reall: clean all
+
+ install:
+- /usr/bin/install -c -o 0 -g 0 -s -m 755 $(EXE) $(INSTALLDIR)/$(EXE)
++ /usr/bin/install -c -o 0 -g 0 -m 755 $(EXE) $(INSTALLDIR)/$(EXE)
+ chmod +s $(INSTALLDIR)/$(EXE)
+
+ uninstall:
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
index 97681240dfe3..977590a065e7 100644
--- a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
+++ b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.7 2009/01/14 15:54:35 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.8 2010/09/09 09:54:32 s4t4n Exp $
+
+inherit eutils
IUSE=""
-MY_P=${P}
-S=${WORKDIR}/${MY_P}
+MY_P="${P}"
+S="${WORKDIR}/${MY_P}/src"
DESCRIPTION="Dockapp for laptop users"
SRC_URI="http://www.dockapps.org/download.php/id/474/${P}.tar.bz2"
@@ -24,20 +26,20 @@ KEYWORDS="~amd64 ~ppc x86"
src_unpack() {
unpack ${A}
+ cd "${S}"
- #Prevent automatic stripping of binaries. Closes bug #252109
- sed -i 's/install -c -o 0 -g 0 -s -m/install -c -o 0 -g 0 -m/' "${S}/src/Makefile"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
}
src_compile() {
- emake CFLAGS="${CFLAGS} -Wall" || die "Compilation failed"
+ emake || die "Compilation failed"
}
src_install() {
dodir /usr/bin
einstall INSTALLDIR="${D}/usr/bin" || die "Installation failed"
- dodoc AUTHORS README README.IT THANKS
+ dodoc ../AUTHORS ../README ../README.IT ../THANKS
insinto /usr/share/applications
doins "${FILESDIR}/${PN}.desktop"