summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-14 09:30:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-14 09:30:11 +0000
commit2aeb305da66be76d2e0d3ff6f25b1fd8e5e83dd3 (patch)
tree45b4330c98bb67ce66a81d80c05183c5e293ceeb /sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
parentFix bug #226887. (diff)
downloadgentoo-2-2aeb305da66be76d2e0d3ff6f25b1fd8e5e83dd3.tar.gz
gentoo-2-2aeb305da66be76d2e0d3ff6f25b1fd8e5e83dd3.tar.bz2
gentoo-2-2aeb305da66be76d2e0d3ff6f25b1fd8e5e83dd3.zip
Bug #226923, fix append-ldflags usage.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-apps/hwsetup/hwsetup-1.2-r1.ebuild')
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild b/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
index 77f3c72f383a..07278a5109a9 100644
--- a/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild,v 1.2 2008/09/04 12:39:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild,v 1.3 2008/10/14 09:30:11 robbat2 Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -39,11 +39,11 @@ src_unpack() {
src_compile() {
append-ldflags -s
filter-ldflags -Wl,--as-needed --as-needed
- if use zlib
- then
- append-ldflags -lz
- elif built_with_use --missing false sys-apps/pciutils zlib
- then
+ if use zlib ; then
+ sed -i \
+ -e '/^LIBS=/s,-lpci,-lz -lpci,g' \
+ Makefile
+ elif built_with_use --missing false sys-apps/pciutils zlib ; then
die "You need to build with USE=zlib to match sys-apps/pcituils"
fi
emake LDFLAGS="${LDFLAGS}" OPT="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"