summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/hwsetup/ChangeLog5
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2-r1.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index 11f8ae82a909..4ba1f2e3d671 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.57 2008/09/04 12:39:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.58 2008/10/14 09:30:11 robbat2 Exp $
+
+ 14 Oct 2008; Robin H. Johnson <robbat2@gentoo.org> hwsetup-1.2-r1.ebuild:
+ Bug #226923, fix append-ldflags usage.
04 Sep 2008; Ben de Groot <yngwin@gentoo.org> hwsetup-1.2-r1.ebuild:
Unmasking and stabilizing latest version, adding warning, on behalf of
diff --git a/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild b/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
index 77f3c72f383a..07278a5109a9 100644
--- a/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild,v 1.2 2008/09/04 12:39:37 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2-r1.ebuild,v 1.3 2008/10/14 09:30:11 robbat2 Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -39,11 +39,11 @@ src_unpack() {
src_compile() {
append-ldflags -s
filter-ldflags -Wl,--as-needed --as-needed
- if use zlib
- then
- append-ldflags -lz
- elif built_with_use --missing false sys-apps/pciutils zlib
- then
+ if use zlib ; then
+ sed -i \
+ -e '/^LIBS=/s,-lpci,-lz -lpci,g' \
+ Makefile
+ elif built_with_use --missing false sys-apps/pciutils zlib ; then
die "You need to build with USE=zlib to match sys-apps/pcituils"
fi
emake LDFLAGS="${LDFLAGS}" OPT="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"