summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2004-10-29 18:38:39 +0000
committerCarsten Lohrke <carlo@gentoo.org>2004-10-29 18:38:39 +0000
commit25c7268090e3e52c80018ba64fde9796ad911dea (patch)
tree192115e4f69b1b58dda391e8ed2bcd157a5d4960 /net-nds/luma
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-25c7268090e3e52c80018ba64fde9796ad911dea.tar.gz
gentoo-2-25c7268090e3e52c80018ba64fde9796ad911dea.tar.bz2
gentoo-2-25c7268090e3e52c80018ba64fde9796ad911dea.zip
small patch, #66453
Diffstat (limited to 'net-nds/luma')
-rw-r--r--net-nds/luma/ChangeLog6
-rw-r--r--net-nds/luma/files/winpopup-error.patch54
-rw-r--r--net-nds/luma/luma-1.4.ebuild14
3 files changed, 70 insertions, 4 deletions
diff --git a/net-nds/luma/ChangeLog b/net-nds/luma/ChangeLog
index 1ddb00bb3295..eed3e904f5d1 100644
--- a/net-nds/luma/ChangeLog
+++ b/net-nds/luma/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nds/luma
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/luma/ChangeLog,v 1.3 2004/08/20 00:09:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/luma/ChangeLog,v 1.4 2004/10/29 18:38:39 carlo Exp $
+
+ 29 Oct 2004; Carsten Lohrke <carlo@gentoo.org> +files/winpopup-error.patch,
+ luma-1.4.ebuild:
+ small patch, #66453
*luma-1.4 (20 Aug 2004)
diff --git a/net-nds/luma/files/winpopup-error.patch b/net-nds/luma/files/winpopup-error.patch
new file mode 100644
index 000000000000..3564b875be07
--- /dev/null
+++ b/net-nds/luma/files/winpopup-error.patch
@@ -0,0 +1,54 @@
+Index: lib/luma/base/utils/gui/SearchResultView.py
+===================================================================
+RCS file: /cvsroot/luma/luma/lib/luma/base/utils/gui/SearchResultView.py,v
+retrieving revision 1.14
+retrieving revision 1.15
+diff -U3 -r1.14 -r1.15
+--- lib/luma/base/utils/gui/SearchResultView.py 8 Jul 2004 20:39:16 -0000 1.14
++++ lib/luma/base/utils/gui/SearchResultView.py 25 Aug 2004 16:07:16 -0000 1.15
+@@ -50,18 +50,14 @@
+
+ def show_entry(self, listItem):
+ while len(self.childsToClean) > 0:
+- number = -1
+- for x in range(0, len(self.childWidgets)):
+- name1 = self.childWidgets[x].name()
+- name2 = self.childsToClean[0]
+- if name1 == name2:
+- number = x
+- if not(number == -1):
+- del self.childWidgets[number]
+- del self.childsToClean[0]
++ childName = self.childsToClean[0]
++ childIndex = self.childWidgets.index(childName)
++ del self.childWidgets[childIndex]
++ del self.childsToClean[0]
+
+- floatingWidget = ChildWindow(None)
++ floatingWidget = ChildWindow(None, unicode(listItem.text(0)).encode('utf-8'))
+ widget = ObjectWidget(floatingWidget, unicode(listItem.text(0)).encode('utf-8'), 0)
++
+ floatingWidget.setCentralWidget(widget)
+ widget.buildToolBar(floatingWidget)
+ values = [self.RESULT[unicode(listItem.text(0)).encode('utf-8')]]
+@@ -127,8 +123,7 @@
+
+ def eventFilter(self, object, event):
+ if (event.type() == QEvent.Close):
+- name = object.name()
+- self.childsToClean.append(name)
++ self.childsToClean.append(object)
+ return 0
+
+ ###############################################################################
+@@ -252,8 +247,8 @@
+
+ class ChildWindow(QMainWindow):
+
+- def __init__(self, parent = None):
+- QMainWindow.__init__(self)
++ def __init__(self, parent = None, name= None):
++ QMainWindow.__init__(self, parent, name)
+
+
+ def closeEvent(self, event):
diff --git a/net-nds/luma/luma-1.4.ebuild b/net-nds/luma/luma-1.4.ebuild
index 8d369e55a8e0..4dce413e68a9 100644
--- a/net-nds/luma/luma-1.4.ebuild
+++ b/net-nds/luma/luma-1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/luma/luma-1.4.ebuild,v 1.1 2004/08/20 00:09:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/luma/luma-1.4.ebuild,v 1.2 2004/10/29 18:38:39 carlo Exp $
+
+inherit eutils
DESCRIPTION="Luma is a graphical utility for accessing and managing data stored on LDAP servers."
HOMEPAGE="http://luma.sourceforge.net/"
@@ -21,10 +23,16 @@ RDEPEND=">=x11-libs/qt-3.2
DEPEND=">=x11-libs/qt-3.2
>=dev-lang/python-2.3
>=dev-python/PyQt-3.10
- >=dev-python/python-ldap-2.0.0_pre13
+ >=dev-python/python-ldap-2.0.1
samba? ( >=dev-python/py-smbpasswd-1.0 )"
-src_install () {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/winpopup-error.patch
+}
+
+src_install() {
dodir /usr
python install.py --prefix=${D}/usr
}