summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/luma/luma-1.4.ebuild')
-rw-r--r--net-nds/luma/luma-1.4.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-nds/luma/luma-1.4.ebuild b/net-nds/luma/luma-1.4.ebuild
index 8d369e55a8e0..4dce413e68a9 100644
--- a/net-nds/luma/luma-1.4.ebuild
+++ b/net-nds/luma/luma-1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/luma/luma-1.4.ebuild,v 1.1 2004/08/20 00:09:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/luma/luma-1.4.ebuild,v 1.2 2004/10/29 18:38:39 carlo Exp $
+
+inherit eutils
DESCRIPTION="Luma is a graphical utility for accessing and managing data stored on LDAP servers."
HOMEPAGE="http://luma.sourceforge.net/"
@@ -21,10 +23,16 @@ RDEPEND=">=x11-libs/qt-3.2
DEPEND=">=x11-libs/qt-3.2
>=dev-lang/python-2.3
>=dev-python/PyQt-3.10
- >=dev-python/python-ldap-2.0.0_pre13
+ >=dev-python/python-ldap-2.0.1
samba? ( >=dev-python/py-smbpasswd-1.0 )"
-src_install () {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/winpopup-error.patch
+}
+
+src_install() {
dodir /usr
python install.py --prefix=${D}/usr
}