summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2006-10-16 20:10:37 +0000
committerOlivier Crête <tester@gentoo.org>2006-10-16 20:10:37 +0000
commitf7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15 (patch)
treeb19e20fe49be3191a80d9b1a6e0cc7f2ef0188cb /media-libs/libgpod/libgpod-0.4.0.ebuild
parentTake ownership, version bump, closes bug#149562 (diff)
downloadgentoo-2-f7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15.tar.gz
gentoo-2-f7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15.tar.bz2
gentoo-2-f7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15.zip
Fix compilation without gtk, bug #149018
(Portage version: 2.1.1-r1)
Diffstat (limited to 'media-libs/libgpod/libgpod-0.4.0.ebuild')
-rw-r--r--media-libs/libgpod/libgpod-0.4.0.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/media-libs/libgpod/libgpod-0.4.0.ebuild b/media-libs/libgpod/libgpod-0.4.0.ebuild
index 85c032f2bab3..6eb06af4d169 100644
--- a/media-libs/libgpod/libgpod-0.4.0.ebuild
+++ b/media-libs/libgpod/libgpod-0.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.4.0.ebuild,v 1.3 2006/10/15 21:08:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.4.0.ebuild,v 1.4 2006/10/16 20:10:37 tester Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Shared library to access the contents of an iPod"
HOMEPAGE="http://www.gtkpod.org/libgpod.html"
@@ -22,6 +22,20 @@ DEPEND="${RDEPEND}
sys-devel/autoconf
sys-devel/libtool
>=dev-util/intltool-0.2.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/libgpod-0.4.0-test-nogdk.patch
+
+ # Dont run aclocal, it breaks
+ eautomake
+ eautoconf
+ eautoheader
+ elibtoolize
+}
+
src_compile() {
econf $(use_enable gtk gdk-pixbuf) \