summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2006-10-16 20:10:37 +0000
committerOlivier Crête <tester@gentoo.org>2006-10-16 20:10:37 +0000
commitf7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15 (patch)
treeb19e20fe49be3191a80d9b1a6e0cc7f2ef0188cb /media-libs/libgpod
parentTake ownership, version bump, closes bug#149562 (diff)
downloadgentoo-2-f7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15.tar.gz
gentoo-2-f7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15.tar.bz2
gentoo-2-f7e5bd9eafe29076b1ce87d38d5d1ae4af2a5f15.zip
Fix compilation without gtk, bug #149018
(Portage version: 2.1.1-r1)
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/ChangeLog6
-rw-r--r--media-libs/libgpod/files/libgpod-0.4.0-test-nogdk.patch31
-rw-r--r--media-libs/libgpod/libgpod-0.4.0.ebuild18
-rw-r--r--media-libs/libgpod/metadata.xml4
4 files changed, 56 insertions, 3 deletions
diff --git a/media-libs/libgpod/ChangeLog b/media-libs/libgpod/ChangeLog
index b0e4e430c831..6281d0319460 100644
--- a/media-libs/libgpod/ChangeLog
+++ b/media-libs/libgpod/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libgpod
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.18 2006/10/15 21:08:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/ChangeLog,v 1.19 2006/10/16 20:10:37 tester Exp $
+
+ 16 Oct 2006; Olivier Crête <tester@gentoo.org>
+ +files/libgpod-0.4.0-test-nogdk.patch, metadata.xml, libgpod-0.4.0.ebuild:
+ Fix compilation without gtk, bug #149018
15 Oct 2006; Aron Griffis <agriffis@gentoo.org> libgpod-0.4.0.ebuild:
Mark 0.4.0 ~ia64
diff --git a/media-libs/libgpod/files/libgpod-0.4.0-test-nogdk.patch b/media-libs/libgpod/files/libgpod-0.4.0-test-nogdk.patch
new file mode 100644
index 000000000000..75515daf4361
--- /dev/null
+++ b/media-libs/libgpod/files/libgpod-0.4.0-test-nogdk.patch
@@ -0,0 +1,31 @@
+--- tests/test-init-ipod.c.orig 2006-10-16 15:48:29.000000000 -0400
++++ tests/test-init-ipod.c 2006-10-16 15:48:44.000000000 -0400
+@@ -26,7 +26,7 @@
+ #include "itdb.h"
+
+ #include <locale.h>
+-#include <gdk-pixbuf/gdk-pixbuf.h>
++#include <glib-object.h>
+ #include <glib/gi18n-lib.h>
+
+
+--- tests/Makefile.am.orig 2006-10-16 15:56:24.000000000 -0400
++++ tests/Makefile.am 2006-10-16 15:57:45.000000000 -0400
+@@ -23,6 +23,8 @@
+ test_ls_SOURCES = test-ls.c
+ test_ls_LDADD =
+
++test_init_ipod_SOURCES = test-init-ipod.c
++
+ if HAVE_TAGLIB
+ test_rebuild_db_SOURCES = test-rebuild-db.cc
+ test_rebuild_db_LDADD = $(TAGLIB_LIBS)
+@@ -36,8 +38,6 @@
+ test_photos_SOURCES = test-photos.c
+ test_photos_CFLAGS = $(AM_CFLAGS)
+
+-test_init_ipod_SOURCES = test-init-ipod.c
+-
+ test_write_thumbnails_SOURCES = test-write-covers.c
+ test_write_thumbnails_CFLAGS = $(AM_CFLAGS)
+ endif
diff --git a/media-libs/libgpod/libgpod-0.4.0.ebuild b/media-libs/libgpod/libgpod-0.4.0.ebuild
index 85c032f2bab3..6eb06af4d169 100644
--- a/media-libs/libgpod/libgpod-0.4.0.ebuild
+++ b/media-libs/libgpod/libgpod-0.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.4.0.ebuild,v 1.3 2006/10/15 21:08:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgpod/libgpod-0.4.0.ebuild,v 1.4 2006/10/16 20:10:37 tester Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="Shared library to access the contents of an iPod"
HOMEPAGE="http://www.gtkpod.org/libgpod.html"
@@ -22,6 +22,20 @@ DEPEND="${RDEPEND}
sys-devel/autoconf
sys-devel/libtool
>=dev-util/intltool-0.2.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/libgpod-0.4.0-test-nogdk.patch
+
+ # Dont run aclocal, it breaks
+ eautomake
+ eautoconf
+ eautoheader
+ elibtoolize
+}
+
src_compile() {
econf $(use_enable gtk gdk-pixbuf) \
diff --git a/media-libs/libgpod/metadata.xml b/media-libs/libgpod/metadata.xml
index ae51d81b64d4..0b12c97b0728 100644
--- a/media-libs/libgpod/metadata.xml
+++ b/media-libs/libgpod/metadata.xml
@@ -3,6 +3,10 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
+ <email>tester@gentoo.org</email>
+ <name>Olivier Crete</name>
+ </maintainer>
+ <maintainer>
<email>joem@gentoo.org</email>
<name>Joe McCann</name>
</maintainer>