summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-04 14:19:36 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-04 14:19:36 +0000
commitfe2c54d4c8c7b6c4f03d8716a1aa5061ad7d3a5c (patch)
tree83a2895316e6dad01508668d6ab7beb21e9a30fe /kde-base/kdegraphics/kdegraphics-3.5.5.ebuild
parentAdding syck-php-bindings to the tree, for bug #145085 (diff)
downloadgentoo-2-fe2c54d4c8c7b6c4f03d8716a1aa5061ad7d3a5c.tar.gz
gentoo-2-fe2c54d4c8c7b6c4f03d8716a1aa5061ad7d3a5c.tar.bz2
gentoo-2-fe2c54d4c8c7b6c4f03d8716a1aa5061ad7d3a5c.zip
Bump to 3.5.5 (pre-release). Sorry for being late on this, mips disallow repoman commits.
(Portage version: 2.1.2_pre2-r2)
Diffstat (limited to 'kde-base/kdegraphics/kdegraphics-3.5.5.ebuild')
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.5.5.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/kde-base/kdegraphics/kdegraphics-3.5.5.ebuild b/kde-base/kdegraphics/kdegraphics-3.5.5.ebuild
new file mode 100644
index 000000000000..9282c8f908fb
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.5.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.5.5.ebuild,v 1.1 2006/10/04 14:19:36 flameeyes Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gphoto2 imlib openexr opengl pdf povray scanner tetex"
+
+DEPEND="~kde-base/kdebase-${PV}
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ gphoto2? ( media-libs/libgphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ media-libs/libart_lgpl
+ media-libs/lcms
+ dev-libs/fribidi
+ imlib? ( media-libs/imlib )
+ virtual/ghostscript
+ media-libs/tiff
+ openexr? ( >=media-libs/openexr-1.2 )
+ povray? ( media-gfx/povray
+ virtual/opengl )
+ pdf? ( >=app-text/poppler-0.5.1
+ >=app-text/poppler-bindings-0.5.1 )"
+
+RDEPEND="${DEPEND}
+ tetex? (
+ || ( >=app-text/tetex-2
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kpdf-3.5.3-poppler-bis.patch.bz2"
+
+PATCHES="${DISTDIR}/kpdf-3.5.3-poppler-bis.patch.bz2"
+
+pkg_setup() {
+ kde_pkg_setup
+ for ghostscript in app-text/ghostscript-{gnu,esp,afpl}; do
+ if has_version ${ghostscript} && ! built_with_use ${ghostscript} X; then
+ eerror "This package requires ${ghostscript} compiled with X11 support."
+ eerror "Please reemerge ${ghostscript} with USE=\"X\"."
+ die "Please reemerge ${ghostscript} with USE=\"X\"."
+ fi
+ done
+ if use pdf && ! built_with_use app-text/poppler-bindings qt3; then
+ eerror "This package requires app-text/poppler-bindings compiled with Qt 3.x support."
+ eerror "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ die "Please reemerge app-text/poppler-bindings with USE=\"qt3\"."
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_with openexr) $(use_with pdf poppler)
+ $(use_with gphoto2 kamera)"
+
+ use imlib || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kuickshow"
+ use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
+ use povray || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kpovmodeler"
+ use pdf || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kpdf"
+
+ rm -f ${S}/configure # ask rebuilding
+ kde_src_compile
+}