summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-15 19:25:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-15 19:25:25 +0000
commit0558f741374cd02f510874a565e1e45570e9b239 (patch)
treed132c2621b10e7458fad1ac96b6f348debead0f1 /games-puzzle
parentUpdate ChangeLog. (diff)
downloadgentoo-2-0558f741374cd02f510874a565e1e45570e9b239.tar.gz
gentoo-2-0558f741374cd02f510874a565e1e45570e9b239.tar.bz2
gentoo-2-0558f741374cd02f510874a565e1e45570e9b239.zip
use EPYTHON in wrapper (bug #549568)
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/hexamine/ChangeLog5
-rw-r--r--games-puzzle/hexamine/hexamine-0.2.1.ebuild17
2 files changed, 17 insertions, 5 deletions
diff --git a/games-puzzle/hexamine/ChangeLog b/games-puzzle/hexamine/ChangeLog
index 9060448c125e..ed1f7b1251ea 100644
--- a/games-puzzle/hexamine/ChangeLog
+++ b/games-puzzle/hexamine/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/hexamine
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/ChangeLog,v 1.6 2015/03/24 17:25:01 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/ChangeLog,v 1.7 2015/05/15 19:25:25 mr_bones_ Exp $
+
+ 15 May 2015; Michael Sterrett <mr_bones_@gentoo.org> hexamine-0.2.1.ebuild:
+ use EPYTHON in wrapper (bug #549568)
24 Mar 2015; Agostino Sarubbo <ago@gentoo.org> hexamine-0.2.1.ebuild:
Stable for amd64, wrt bug #543222
diff --git a/games-puzzle/hexamine/hexamine-0.2.1.ebuild b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
index be1251482bc7..cc3cdcb46d7f 100644
--- a/games-puzzle/hexamine/hexamine-0.2.1.ebuild
+++ b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/hexamine-0.2.1.ebuild,v 1.5 2015/03/24 17:25:01 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/hexamine-0.2.1.ebuild,v 1.6 2015/05/15 19:25:25 mr_bones_ Exp $
EAPI=5
-inherit games
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 games
DESCRIPTION="Hexagonal Minesweeper"
HOMEPAGE="http://sourceforge.net/projects/hexamine"
@@ -14,15 +15,23 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-RDEPEND="dev-python/pygame"
+RDEPEND="dev-python/pygame
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
src_prepare() {
# Modify game data directory
sed -i \
-e "s:\`dirname \$0\`:${GAMES_DATADIR}/${PN}:" \
- -e "s:\./hexamine:exec python &:" \
+ -e "s:\./hexamine:exec ${EPYTHON} &:" \
hexamine || die
}