summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/hexamine/hexamine-0.2.1.ebuild')
-rw-r--r--games-puzzle/hexamine/hexamine-0.2.1.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/games-puzzle/hexamine/hexamine-0.2.1.ebuild b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
index be1251482bc7..cc3cdcb46d7f 100644
--- a/games-puzzle/hexamine/hexamine-0.2.1.ebuild
+++ b/games-puzzle/hexamine/hexamine-0.2.1.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/hexamine-0.2.1.ebuild,v 1.5 2015/03/24 17:25:01 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/hexamine/hexamine-0.2.1.ebuild,v 1.6 2015/05/15 19:25:25 mr_bones_ Exp $
EAPI=5
-inherit games
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 games
DESCRIPTION="Hexagonal Minesweeper"
HOMEPAGE="http://sourceforge.net/projects/hexamine"
@@ -14,15 +15,23 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
-RDEPEND="dev-python/pygame"
+RDEPEND="dev-python/pygame
+ ${PYTHON_DEPS}"
+DEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S=${WORKDIR}/${PN}
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
src_prepare() {
# Modify game data directory
sed -i \
-e "s:\`dirname \$0\`:${GAMES_DATADIR}/${PN}:" \
- -e "s:\./hexamine:exec python &:" \
+ -e "s:\./hexamine:exec ${EPYTHON} &:" \
hexamine || die
}