summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-13 08:57:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-13 08:57:57 +0000
commitcc6c48d162a257b948f26ea017bba3402e6196db (patch)
treec44367470e8d9b7edfdb9383d3422c459f1fbf36 /games-misc
parentBump to EAPI=5 (diff)
downloadgentoo-2-cc6c48d162a257b948f26ea017bba3402e6196db.tar.gz
gentoo-2-cc6c48d162a257b948f26ea017bba3402e6196db.tar.bz2
gentoo-2-cc6c48d162a257b948f26ea017bba3402e6196db.zip
version bump (bug #508244)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog8
-rw-r--r--games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch16
-rw-r--r--games-misc/opengfx/opengfx-0.5.1.ebuild39
3 files changed, 62 insertions, 1 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index d1e00c1ac348..2e4dcb867017 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-misc/opengfx
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.35 2014/04/21 01:44:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.36 2014/06/13 08:57:57 mr_bones_ Exp $
+
+*opengfx-0.5.1 (13 Jun 2014)
+
+ 13 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/opengfx-0.5.1-gcc48.patch, +opengfx-0.5.1.ebuild:
+ version bump (bug #508244)
21 Apr 2014; Michael Sterrett <mr_bones_@gentoo.org> -opengfx-0.4.5.ebuild:
old
diff --git a/games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch b/games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch
new file mode 100644
index 000000000000..78b512e71cec
--- /dev/null
+++ b/games-misc/opengfx/files/opengfx-0.5.1-gcc48.patch
@@ -0,0 +1,16 @@
+--- scripts/Makefile.nml.old 2013-05-09 20:09:52.992038666 +0200
++++ scripts/Makefile.nml 2013-05-09 20:10:36.942970903 +0200
+@@ -14,11 +14,11 @@
+
+ %.src.dep: $(SRC_DIR)/%.pnml
+ $(_E) "[DEP] $@"
+- $(_V) $(CC) -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
++ $(_V) $(CC) -P -C -M -MF $@ -E -MT $(patsubst %.src.dep,%.nml,$@) - < $<
+
+ %.nml: $(SRC_DIR)/%.pnml $(TAG_FILENAME)
+ $(_E) "[CPP] $@"
+- $(_V) $(CC) -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
++ $(_V) $(CC) -P -D REPO_REVISION=$(REPO_REVISION) $(CC_FLAGS) $< > $@
+
+ %.gfx.dep: %.nml
+ $(_E) "[DEP] $@"
diff --git a/games-misc/opengfx/opengfx-0.5.1.ebuild b/games-misc/opengfx/opengfx-0.5.1.ebuild
new file mode 100644
index 000000000000..33275ac3c798
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.5.1.ebuild,v 1.1 2014/06/13 08:57:57 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.3.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+src_prepare() {
+ # ensure that we will not use gimp to regenerate the pngs
+ # causes sandbox violations and not worth the effort anyway
+ sed -i -e '/^GFX_SCRIPT_LIST_FILES/s/^/#/' Makefile.config || die
+}
+
+src_compile() {
+ _V= emake bundle_tar
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+ prepgamesdirs
+}