summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-12 08:13:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-12 08:13:26 +0000
commitca8d218cdf6d828b819d2d4383c5b327cb14aa24 (patch)
tree16e79aabc3fd3af0939f8a3a7a52244fa0a53022 /dev-python/testscenarios
parentStraighten out py34 keywording (diff)
downloadgentoo-2-ca8d218cdf6d828b819d2d4383c5b327cb14aa24.tar.gz
gentoo-2-ca8d218cdf6d828b819d2d4383c5b327cb14aa24.tar.bz2
gentoo-2-ca8d218cdf6d828b819d2d4383c5b327cb14aa24.zip
Add py34
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/ChangeLog7
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r5.ebuild24
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-python/testscenarios/ChangeLog b/dev-python/testscenarios/ChangeLog
index 4ef9ca53ad50..1bb4e055e27b 100644
--- a/dev-python/testscenarios/ChangeLog
+++ b/dev-python/testscenarios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testscenarios
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.12 2014/06/08 09:47:47 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/ChangeLog,v 1.13 2014/06/12 08:13:26 patrick Exp $
+
+*testscenarios-0.4-r5 (12 Jun 2014)
+
+ 12 Jun 2014; Patrick Lauer <patrick@gentoo.org> +testscenarios-0.4-r5.ebuild:
+ Add py34
08 Jun 2014; Akinori Hattori <hattya@gentoo.org> testscenarios-0.4-r4.ebuild:
keyword ~ia64 wrt bug #508282
diff --git a/dev-python/testscenarios/testscenarios-0.4-r5.ebuild b/dev-python/testscenarios/testscenarios-0.4-r5.ebuild
new file mode 100644
index 000000000000..9e946a511595
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4-r5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/testscenarios-0.4-r5.ebuild,v 1.1 2014/06/12 08:13:26 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy2_0 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
+}