summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testscenarios/testscenarios-0.4-r5.ebuild')
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.4-r5.ebuild b/dev-python/testscenarios/testscenarios-0.4-r5.ebuild
new file mode 100644
index 000000000000..9e946a511595
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4-r5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testscenarios/testscenarios-0.4-r5.ebuild,v 1.1 2014/06/12 08:13:26 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy2_0 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
+}