summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-30 12:57:16 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-30 12:57:16 +0000
commit180cc511da815c178e840914aef355cc285509f4 (patch)
treebcb6fbc54b639113adf984f82098261e12a36fdb /dev-python/sphinxcontrib-googleanalytics
parentamd64 stable wrt bug #525060 (diff)
downloadgentoo-2-180cc511da815c178e840914aef355cc285509f4.tar.gz
gentoo-2-180cc511da815c178e840914aef355cc285509f4.tar.bz2
gentoo-2-180cc511da815c178e840914aef355cc285509f4.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/sphinxcontrib-googleanalytics')
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/ChangeLog11
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild22
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1.ebuild29
3 files changed, 31 insertions, 31 deletions
diff --git a/dev-python/sphinxcontrib-googleanalytics/ChangeLog b/dev-python/sphinxcontrib-googleanalytics/ChangeLog
index 4348fde1806a..92175d80dea5 100644
--- a/dev-python/sphinxcontrib-googleanalytics/ChangeLog
+++ b/dev-python/sphinxcontrib-googleanalytics/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/sphinxcontrib-googleanalytics
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxcontrib-googleanalytics/ChangeLog,v 1.4 2012/10/12 07:04:45 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxcontrib-googleanalytics/ChangeLog,v 1.5 2014/12/30 12:57:16 idella4 Exp $
+
+*sphinxcontrib-googleanalytics-0.1-r1 (30 Dec 2014)
+
+ 30 Dec 2014; Ian Delaney <idella4@gentoo.org>
+ +sphinxcontrib-googleanalytics-0.1-r1.ebuild,
+ -sphinxcontrib-googleanalytics-0.1.ebuild:
+ revbump; conversion -> distutils-r1, rm old
12 Oct 2012; Patrick Lauer <patrick@gentoo.org>
sphinxcontrib-googleanalytics-0.1.ebuild:
diff --git a/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild
new file mode 100644
index 000000000000..ec046d226322
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild,v 1.1 2014/12/30 12:57:16 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension googleanalytics"
+HOMEPAGE="http://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/sphinx-0.6[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/setup.py.utf-8.patch" )
diff --git a/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1.ebuild b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1.ebuild
deleted file mode 100644
index 4b250944a07d..000000000000
--- a/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1.ebuild,v 1.4 2012/10/12 07:04:45 patrick Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-
-inherit distutils eutils
-
-DESCRIPTION="Sphinx extension googleanalytics"
-HOMEPAGE="http://bitbucket.org/birkenfeld/sphinx-contrib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-python/setuptools"
-RDEPEND=">=dev-python/sphinx-0.6"
-
-PYTHON_MODNAME="sphinxcontrib"
-
-src_prepare() {
- epatch "${FILESDIR}/setup.py.utf-8.patch"
- distutils_src_prepare
-}