summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2009-03-11 19:34:01 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2009-03-11 19:34:01 +0000
commit439a123cccd7b478dd92953d63b824be7ca637a3 (patch)
tree71ba928ddd2fa7ca998195862d1a6fcbcf4a2dc8 /dev-cpp/gtkmm
parentx86 stable, bug #259927 (diff)
downloadgentoo-2-439a123cccd7b478dd92953d63b824be7ca637a3.tar.gz
gentoo-2-439a123cccd7b478dd92953d63b824be7ca637a3.tar.bz2
gentoo-2-439a123cccd7b478dd92953d63b824be7ca637a3.zip
Add a big, fat warning about changing the accessibilty USE flag. Bug #247249
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gtkmm')
-rw-r--r--dev-cpp/gtkmm/ChangeLog9
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.12.1.ebuild12
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.12.7.ebuild12
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.14.1.ebuild12
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.14.3.ebuild12
5 files changed, 47 insertions, 10 deletions
diff --git a/dev-cpp/gtkmm/ChangeLog b/dev-cpp/gtkmm/ChangeLog
index 8424e862da8c..4b8c9aae6f2c 100644
--- a/dev-cpp/gtkmm/ChangeLog
+++ b/dev-cpp/gtkmm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gtkmm
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.154 2008/11/14 10:50:29 remi Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.155 2009/03/11 19:34:01 dang Exp $
+
+ 11 Mar 2009; Daniel Gryniewicz <dang@gentoo.org> gtkmm-2.12.1.ebuild,
+ gtkmm-2.12.7.ebuild, gtkmm-2.14.1.ebuild, gtkmm-2.14.3.ebuild:
+ Add a big, fat warning about changing the accessibilty USE flag. Bug
+ #247249
*gtkmm-2.14.3 (14 Nov 2008)
diff --git a/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild b/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild
index da65bc0f61f1..188b1aed78b1 100644
--- a/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild,v 1.12 2008/09/28 14:00:23 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.1.ebuild,v 1.13 2009/03/11 19:34:01 dang Exp $
inherit gnome2 autotools
@@ -37,3 +37,11 @@ src_unpack() {
# Fix build with gtk+-2.14
epatch "${FILESDIR}/${PN}-2.12.7-gtk2_14-compatibility.patch"
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn "If you've changed the accessability USE flag on gtkmm, you've"
+ ewarn "silently broken ABI. You will have to re-emerge everything that"
+ ewarn "depends on gtkmm. You can find those packages with either"
+ ewarn "equery d or qdepends -Q"
+}
diff --git a/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild b/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild
index 2c80cc6e1288..b55172a35f93 100644
--- a/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild,v 1.9 2008/09/30 17:23:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.12.7.ebuild,v 1.10 2009/03/11 19:34:01 dang Exp $
inherit gnome2 eutils
@@ -42,3 +42,11 @@ src_unpack() {
sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
fi
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn "If you've changed the accessability USE flag on gtkmm, you've"
+ ewarn "silently broken ABI. You will have to re-emerge everything that"
+ ewarn "depends on gtkmm. You can find those packages with either"
+ ewarn "equery d or qdepends -Q"
+}
diff --git a/dev-cpp/gtkmm/gtkmm-2.14.1.ebuild b/dev-cpp/gtkmm/gtkmm-2.14.1.ebuild
index 8432e4fc043d..472ebbd9f597 100644
--- a/dev-cpp/gtkmm/gtkmm-2.14.1.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.14.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.14.1.ebuild,v 1.1 2008/11/08 22:52:56 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.14.1.ebuild,v 1.2 2009/03/11 19:34:01 dang Exp $
inherit gnome2
@@ -39,3 +39,11 @@ src_unpack() {
sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
fi
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn "If you've changed the accessability USE flag on gtkmm, you've"
+ ewarn "silently broken ABI. You will have to re-emerge everything that"
+ ewarn "depends on gtkmm. You can find those packages with either"
+ ewarn "equery d or qdepends -Q"
+}
diff --git a/dev-cpp/gtkmm/gtkmm-2.14.3.ebuild b/dev-cpp/gtkmm/gtkmm-2.14.3.ebuild
index 102e28bad156..14023c2ad911 100644
--- a/dev-cpp/gtkmm/gtkmm-2.14.3.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-2.14.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.14.3.ebuild,v 1.1 2008/11/14 10:50:29 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.14.3.ebuild,v 1.2 2009/03/11 19:34:01 dang Exp $
inherit gnome2
@@ -38,3 +38,11 @@ src_unpack() {
sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
fi
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ ewarn "If you've changed the accessability USE flag on gtkmm, you've"
+ ewarn "silently broken ABI. You will have to re-emerge everything that"
+ ewarn "depends on gtkmm. You can find those packages with either"
+ ewarn "equery d or qdepends -Q"
+}