summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2004-01-28 23:22:32 +0000
committerRyan Phillips <rphillips@gentoo.org>2004-01-28 23:22:32 +0000
commit45f3fc5bf0e08fe99a5e779c1b05498bf4475494 (patch)
tree59d17b976f5cb25c7ec841bddf49755f7a83fd7f /app-editors/gvim/gvim-6.2-r6.ebuild
parentadded -r6 for patches up to 214 (diff)
downloadgentoo-2-45f3fc5bf0e08fe99a5e779c1b05498bf4475494.tar.gz
gentoo-2-45f3fc5bf0e08fe99a5e779c1b05498bf4475494.tar.bz2
gentoo-2-45f3fc5bf0e08fe99a5e779c1b05498bf4475494.zip
added -r6 for patches up to 214
Diffstat (limited to 'app-editors/gvim/gvim-6.2-r6.ebuild')
-rw-r--r--app-editors/gvim/gvim-6.2-r6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-6.2-r6.ebuild b/app-editors/gvim/gvim-6.2-r6.ebuild
new file mode 100644
index 000000000000..4af25a4baf74
--- /dev/null
+++ b/app-editors/gvim/gvim-6.2-r6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.2-r6.ebuild,v 1.1 2004/01/28 23:22:25 rphillips Exp $
+
+inherit vim
+
+VIM_VERSION="6.2"
+VIM_GENTOO_PATCHES="vim-6.2.069-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-6.2.214-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Graphical Vim"
+KEYWORDS="~alpha ~ppc ~sparc ~x86 ~amd64 ~ia64 ~hppa"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-base/xfree
+ gtk? ( gtk2? ( >=x11-libs/gtk+-2.1 virtual/xft ) ) :
+ ( gnome? ( gnome-base/gnome-libs ) :
+ ( gtk? ( =x11-libs/gtk+-1.2* ) :
+ ( motif? ( x11-libs/openmotif ) ) ) )"