summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/gvim/ChangeLog7
-rw-r--r--app-editors/gvim/Manifest4
-rw-r--r--app-editors/gvim/files/digest-gvim-6.2-r64
-rw-r--r--app-editors/gvim/gvim-6.2-r6.ebuild27
-rw-r--r--app-editors/vim-core/ChangeLog7
-rw-r--r--app-editors/vim-core/Manifest4
-rw-r--r--app-editors/vim-core/files/digest-vim-core-6.2-r64
-rw-r--r--app-editors/vim-core/vim-core-6.2-r6.ebuild20
-rw-r--r--app-editors/vim/ChangeLog7
-rw-r--r--app-editors/vim/Manifest4
-rw-r--r--app-editors/vim/files/digest-vim-6.2-r64
-rw-r--r--app-editors/vim/vim-6.2-r6.ebuild22
12 files changed, 105 insertions, 9 deletions
diff --git a/app-editors/gvim/ChangeLog b/app-editors/gvim/ChangeLog
index 6a1484077c36..6d55e2a8e04b 100644
--- a/app-editors/gvim/ChangeLog
+++ b/app-editors/gvim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gvim
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.54 2004/01/11 13:31:14 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/ChangeLog,v 1.55 2004/01/28 23:22:25 rphillips Exp $
+
+*gvim-6.2-r6 (28 Jan 2004)
+
+ 28 Jan 2004; <rphillips@gentoo.org> gvim-6.2-r6.ebuild:
+ added -r6 with patches up to 214
11 Jan 2004; Heinrich Wendel <lanius@gentoo.org> gvim-6.2-r1.ebuild,
gvim-6.2-r2.ebuild, gvim-6.2-r3.ebuild, gvim-6.2-r5.ebuild, gvim-6.2.ebuild:
diff --git a/app-editors/gvim/Manifest b/app-editors/gvim/Manifest
index 3a6c1aa46f53..4daa814a09ec 100644
--- a/app-editors/gvim/Manifest
+++ b/app-editors/gvim/Manifest
@@ -1,9 +1,9 @@
MD5 f368c288cabe78f89dccb7bc654eeb2d gvim-6.2-r3.ebuild 942
MD5 393f29796599d326ecc9f1f7048a2739 gvim-6.2-r5.ebuild 960
MD5 06956b0d527e5286f0af3fceb43e77c7 gvim-6.2-r2.ebuild 944
-MD5 4e312be3b201dadbceb543f6671a3081 gvim-6.2-r6.ebuild 966
+MD5 026bd5ee3d5d4d9d292a2062bfff6f33 gvim-6.2-r6.ebuild 968
MD5 3756846f9968cfbe36549d251bfbe935 gvim-6.2-r1.ebuild 946
-MD5 bd857aacfd69941bd0915e24e8e3714c ChangeLog 8733
+MD5 26c5228e018d5ad588cfae13d07696ab ChangeLog 8858
MD5 f80ba9ce9c07c43a2c7e421ff7bf2cba gvim-6.2.ebuild 941
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 9e6738a1dd0f4e78cf1b0c8dc0866af7 files/digest-gvim-6.2 274
diff --git a/app-editors/gvim/files/digest-gvim-6.2-r6 b/app-editors/gvim/files/digest-gvim-6.2-r6
new file mode 100644
index 000000000000..7ed30054caee
--- /dev/null
+++ b/app-editors/gvim/files/digest-gvim-6.2-r6
@@ -0,0 +1,4 @@
+MD5 c49d360bbd069d00e2a57804f2a123d9 vim-6.2.tar.bz2 3269791
+MD5 aa0079938f636d08be71078933477d8b vim-6.2-lang.tar.gz 1093788
+MD5 b353829e1201637a64b6569fcff841de vim-6.2.069-gentoo-patches.tar.bz2 4005
+MD5 2ba2149aa94b99bf33efc80e5f42310f vim-6.2.214-patches.tar.bz2 354295
diff --git a/app-editors/gvim/gvim-6.2-r6.ebuild b/app-editors/gvim/gvim-6.2-r6.ebuild
new file mode 100644
index 000000000000..4af25a4baf74
--- /dev/null
+++ b/app-editors/gvim/gvim-6.2-r6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-6.2-r6.ebuild,v 1.1 2004/01/28 23:22:25 rphillips Exp $
+
+inherit vim
+
+VIM_VERSION="6.2"
+VIM_GENTOO_PATCHES="vim-6.2.069-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-6.2.214-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Graphical Vim"
+KEYWORDS="~alpha ~ppc ~sparc ~x86 ~amd64 ~ia64 ~hppa"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-base/xfree
+ gtk? ( gtk2? ( >=x11-libs/gtk+-2.1 virtual/xft ) ) :
+ ( gnome? ( gnome-base/gnome-libs ) :
+ ( gtk? ( =x11-libs/gtk+-1.2* ) :
+ ( motif? ( x11-libs/openmotif ) ) ) )"
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 0b9f5290422a..99ad237904bc 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.55 2003/12/29 02:38:39 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.56 2004/01/28 23:21:01 rphillips Exp $
+
+*vim-core-6.2-r6 (28 Jan 2004)
+
+ 28 Jan 2004; <rphillips@gentoo.org> vim-core-6.2-r6.ebuild:
+ Added -r6 to support patches up to 214
28 Dec 2003; Joshua Kinard <kumba@gentoo.org> vim-core-6.2-r5.ebuild:
Move to mips stable (~mips -> mips)
diff --git a/app-editors/vim-core/Manifest b/app-editors/vim-core/Manifest
index 1b1f4b6a72a8..ce054b4c3772 100644
--- a/app-editors/vim-core/Manifest
+++ b/app-editors/vim-core/Manifest
@@ -1,11 +1,11 @@
MD5 1e47754ccb2bbe0c1d4b2d62853c1982 vim-core-6.2.ebuild 794
-MD5 97f9d4762ee50f2d43f541261e3c6279 vim-core-6.2-r6.ebuild 795
+MD5 a2117f24b25f1bb10aff66b924c6eb3a vim-core-6.2-r6.ebuild 805
MD5 28a8bcc8f4ac7d78c166fb4804b14d19 vim-core-6.2-r1.ebuild 791
MD5 b1ff9c419fa27b783ddac67b1d58e79a vim-core-6.2-r3.ebuild 792
MD5 1be16898ec1e9e07e7af7eed77c2e4bf vim-core-6.2-r5.ebuild 795
MD5 af9a024c24fa3d45a280428d49213d80 vim-core-6.2-r2.ebuild 796
MD5 f6f5abdcd3ae258ccfd5483c0df45448 vim-core-6.2-r4.ebuild 790
-MD5 f4228545f94184dbf0c22cfa99471044 ChangeLog 7584
+MD5 f936ea0ced413fafd57ac0bcf3a37e5d ChangeLog 7724
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 cc4d15465625e4d581e621d3d457d682 files/vimrc 2857
MD5 c2d0302eae7fc80b2a1cb38ddab9d3d3 files/rphillips-invalcolorpatch.diff 722
diff --git a/app-editors/vim-core/files/digest-vim-core-6.2-r6 b/app-editors/vim-core/files/digest-vim-core-6.2-r6
new file mode 100644
index 000000000000..7ed30054caee
--- /dev/null
+++ b/app-editors/vim-core/files/digest-vim-core-6.2-r6
@@ -0,0 +1,4 @@
+MD5 c49d360bbd069d00e2a57804f2a123d9 vim-6.2.tar.bz2 3269791
+MD5 aa0079938f636d08be71078933477d8b vim-6.2-lang.tar.gz 1093788
+MD5 b353829e1201637a64b6569fcff841de vim-6.2.069-gentoo-patches.tar.bz2 4005
+MD5 2ba2149aa94b99bf33efc80e5f42310f vim-6.2.214-patches.tar.bz2 354295
diff --git a/app-editors/vim-core/vim-core-6.2-r6.ebuild b/app-editors/vim-core/vim-core-6.2-r6.ebuild
new file mode 100644
index 000000000000..06d68dc24286
--- /dev/null
+++ b/app-editors/vim-core/vim-core-6.2-r6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.2-r6.ebuild,v 1.1 2004/01/28 23:21:01 rphillips Exp $
+
+inherit vim
+
+VIM_VERSION="6.2"
+VIM_GENTOO_PATCHES="vim-6.2.069-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-6.2.214-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86 ~amd64 ~ia64"
+DEPEND="${DEPEND}" # all the deps for vim-core are in vim.eclass
diff --git a/app-editors/vim/ChangeLog b/app-editors/vim/ChangeLog
index df49a916e838..a3b3d4697039 100644
--- a/app-editors/vim/ChangeLog
+++ b/app-editors/vim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/vim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.82 2003/12/29 02:35:58 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/ChangeLog,v 1.83 2004/01/28 23:21:59 rphillips Exp $
+
+*vim-6.2-r6 (28 Jan 2004)
+
+ 28 Jan 2004; <rphillips@gentoo.org> vim-6.2-r6.ebuild:
+ added -r6 with patche up to 214
28 Dec 2003; Joshua Kinard <kumba@gentoo.org> vim-6.2-r5.ebuild:
Move to mips stable (~mips -> mips)
diff --git a/app-editors/vim/Manifest b/app-editors/vim/Manifest
index d76169f58cfa..ef9b3537dfa9 100644
--- a/app-editors/vim/Manifest
+++ b/app-editors/vim/Manifest
@@ -1,9 +1,9 @@
MD5 e4aca125645ad7f0f7bcddf2f6a6caac vim-6.2-r3.ebuild 774
MD5 f05dd52d2e6945a5f387485e8f2da530 vim-6.2-r5.ebuild 779
MD5 fc5912330f03be70f7e65e16ae039030 vim-6.2-r2.ebuild 768
-MD5 895b37e404c71062c594c99f65dfe659 vim-6.2-r6.ebuild 785
+MD5 bf410ae5e612990498a7d5acaafb1050 vim-6.2-r6.ebuild 789
MD5 dab97fed6dad404ea6304849abaf860f vim-6.2-r1.ebuild 773
-MD5 a418d761f4c30eeb82df45d3ef10095f ChangeLog 13776
+MD5 88ec22aba313d090fcea6e8d65bcb47a ChangeLog 13899
MD5 9244a0b045b3b65e3e9e427ac15a8b5f vim-6.2.ebuild 765
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 9e6738a1dd0f4e78cf1b0c8dc0866af7 files/digest-vim-6.2 274
diff --git a/app-editors/vim/files/digest-vim-6.2-r6 b/app-editors/vim/files/digest-vim-6.2-r6
new file mode 100644
index 000000000000..7ed30054caee
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.2-r6
@@ -0,0 +1,4 @@
+MD5 c49d360bbd069d00e2a57804f2a123d9 vim-6.2.tar.bz2 3269791
+MD5 aa0079938f636d08be71078933477d8b vim-6.2-lang.tar.gz 1093788
+MD5 b353829e1201637a64b6569fcff841de vim-6.2.069-gentoo-patches.tar.bz2 4005
+MD5 2ba2149aa94b99bf33efc80e5f42310f vim-6.2.214-patches.tar.bz2 354295
diff --git a/app-editors/vim/vim-6.2-r6.ebuild b/app-editors/vim/vim-6.2-r6.ebuild
new file mode 100644
index 000000000000..3b213a331ae7
--- /dev/null
+++ b/app-editors/vim/vim-6.2-r6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.2-r6.ebuild,v 1.1 2004/01/28 23:21:59 rphillips Exp $
+
+inherit vim
+
+VIM_VERSION="6.2"
+VIM_GENTOO_PATCHES="vim-6.2.069-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-6.2.214-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86 ~amd64 ~ia64"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}"