summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-08-03 14:10:43 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-08-03 14:10:43 +0000
commitf2aae96e278cd6be0952914c287c595513876ff8 (patch)
treee486807bc062b58f1214f4aa95396c6e6f4ee4d4 /app-admin/webapp-config/webapp-config-9999.ebuild
parentnew upstream release (diff)
downloadgentoo-2-f2aae96e278cd6be0952914c287c595513876ff8.tar.gz
gentoo-2-f2aae96e278cd6be0952914c287c595513876ff8.tar.bz2
gentoo-2-f2aae96e278cd6be0952914c287c595513876ff8.zip
Add python3, re-introduce fix for bug #474968
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-admin/webapp-config/webapp-config-9999.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 666f64919cd9..f3ac72dfac35 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,14 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.3 2013/08/03 13:56:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.4 2013/08/03 14:10:43 blueness Exp $
EAPI="5"
-# We need to fix 'import md5' for the tests before
-# we can be 3.x compat. Uncomment when done.
-#PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
inherit distutils-r1
@@ -27,8 +23,10 @@ HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
LICENSE="GPL-2"
SLOT="0"
+IUSE="+portage"
DEPEND="app-text/xmlto"
+RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
python_compile_all() {
emake -C doc/