summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/webapp-config/ChangeLog6
-rw-r--r--app-admin/webapp-config/webapp-config-1.51.ebuild22
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild10
3 files changed, 15 insertions, 23 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index 33375efd6d53..25d57cd10959 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/webapp-config
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.92 2013/08/03 14:03:05 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.93 2013/08/03 14:10:43 blueness Exp $
+
+ 03 Aug 2013; Anthony G. Basile <blueness@gentoo.org>
+ webapp-config-1.51.ebuild, webapp-config-9999.ebuild:
+ Add python3, re-introduce fix for bug #474968
03 Aug 2013; Anthony G. Basile <blueness@gentoo.org>
webapp-config-1.50.19-r1.ebuild:
diff --git a/app-admin/webapp-config/webapp-config-1.51.ebuild b/app-admin/webapp-config/webapp-config-1.51.ebuild
index a3ca993a782b..df090776b6e2 100644
--- a/app-admin/webapp-config/webapp-config-1.51.ebuild
+++ b/app-admin/webapp-config/webapp-config-1.51.ebuild
@@ -1,34 +1,24 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.51.ebuild,v 1.1 2013/08/03 13:56:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.51.ebuild,v 1.2 2013/08/03 14:10:43 blueness Exp $
EAPI="5"
-# We need to fix 'import md5' for the tests before
-# we can be 3.x compat. Uncomment when done.
-#PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
inherit distutils-r1
-if [[ ${PV} = 9999* ]]
-then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
- inherit git-2
- KEYWORDS=""
-else
- SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-fi
-
DESCRIPTION="Gentoo's installer for web-based applications"
HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
+SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+portage"
DEPEND="app-text/xmlto"
+RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
python_compile_all() {
emake -C doc/
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 666f64919cd9..f3ac72dfac35 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,14 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.3 2013/08/03 13:56:20 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.4 2013/08/03 14:10:43 blueness Exp $
EAPI="5"
-# We need to fix 'import md5' for the tests before
-# we can be 3.x compat. Uncomment when done.
-#PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
inherit distutils-r1
@@ -27,8 +23,10 @@ HOMEPAGE="http://sourceforge.net/projects/webapp-config/"
LICENSE="GPL-2"
SLOT="0"
+IUSE="+portage"
DEPEND="app-text/xmlto"
+RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
python_compile_all() {
emake -C doc/