summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-10 10:28:10 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-10 10:28:10 +0000
commitb67890fc30124bfc5c15bb6ef5b6ba67b11e1770 (patch)
tree7af20a7fe3736896072f67216960bd558c7554db
parentStable for amd64 wrt bug #502914 (diff)
downloadgentoo-2-b67890fc30124bfc5c15bb6ef5b6ba67b11e1770.tar.gz
gentoo-2-b67890fc30124bfc5c15bb6ef5b6ba67b11e1770.tar.bz2
gentoo-2-b67890fc30124bfc5c15bb6ef5b6ba67b11e1770.zip
bump; cease using redundant patch, update dep, tidy test phase, rm olds
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/wsgiintercept/ChangeLog7
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.5.1.ebuild27
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild35
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild38
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.2.ebuild38
-rw-r--r--dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild8
6 files changed, 9 insertions, 144 deletions
diff --git a/dev-python/wsgiintercept/ChangeLog b/dev-python/wsgiintercept/ChangeLog
index 7132d7d9f4c6..7459664e8a20 100644
--- a/dev-python/wsgiintercept/ChangeLog
+++ b/dev-python/wsgiintercept/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wsgiintercept
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.7 2014/06/09 07:56:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/ChangeLog,v 1.8 2014/06/10 10:28:10 idella4 Exp $
+
+ 10 Jun 2014; Ian Delaney <idella4@gentoo.org> -wsgiintercept-0.5.1.ebuild,
+ -wsgiintercept-0.6.0.ebuild, -wsgiintercept-0.6.1.ebuild,
+ -wsgiintercept-0.6.2.ebuild, wsgiintercept-0.6.4.ebuild:
+ bump; cease using redundant patch, update dep, tidy test phase, rm olds
*wsgiintercept-0.6.4 (09 Jun 2014)
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.5.1.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.5.1.ebuild
deleted file mode 100644
index 4018dc266518..000000000000
--- a/dev-python/wsgiintercept/wsgiintercept-0.5.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.5.1.ebuild,v 1.1 2013/07/03 13:14:24 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="wsgi_intercept"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI application in place of a real URI for testing"
-HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://code.google.com/p/wsgi-intercept/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
-"
-
-S="${WORKDIR}"/${MY_P}
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild
deleted file mode 100644
index e0c47deaa4fb..000000000000
--- a/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.0.ebuild,v 1.1 2013/11/27 16:13:23 dev-zero Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-MY_PN="wsgi_intercept"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI application in place of a real URI for testing"
-HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/${PV}-fix-tests.patch" )
-
-python_test() {
- py.test || die
-}
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild
deleted file mode 100644
index e5a200d9f5a1..000000000000
--- a/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.1.ebuild,v 1.1 2014/02/03 12:41:58 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-MY_PN="wsgi_intercept"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI application in place of a real URI for testing"
-HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/0.6.0-fix-tests.patch" )
-
-python_test() {
- py.test || die
-}
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.2.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.2.ebuild
deleted file mode 100644
index fce0bdb43e2a..000000000000
--- a/dev-python/wsgiintercept/wsgiintercept-0.6.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.2.ebuild,v 1.1 2014/05/03 08:25:39 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-MY_PN="wsgi_intercept"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="WSGI application in place of a real URI for testing"
-HOMEPAGE="https://pypi.python.org/pypi/wsgi_intercept https://github.com/cdent/python3-wsgi-intercept"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}/0.6.0-fix-tests.patch" )
-
-python_test() {
- py.test || die
-}
diff --git a/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild b/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild
index bf2ec47c3914..e5cadbf8f10f 100644
--- a/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild
+++ b/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild,v 1.1 2014/06/09 07:56:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wsgiintercept/wsgiintercept-0.6.4.ebuild,v 1.2 2014/06/10 10:28:10 idella4 Exp $
EAPI=5
@@ -26,13 +26,11 @@ DEPEND="
test? (
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/pytest-2.4[${PYTHON_USEDEP}]
- >=dev-python/requests-2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${MY_P}"
-_PATCHES=( "${FILESDIR}/0.6.0-fix-tests.patch" )
-
python_test() {
- py.test || die
+ py.test || die "Tests failed under ${EPYTHON}"
}