summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoel Darlow <mail@mcgruff.plus.com>2012-05-05 17:01:26 +0100
committerNoel Darlow <mail@mcgruff.plus.com>2012-05-05 17:01:26 +0100
commit62fc0e82f038e1f8c1c434e1fb39c45b8f2fd0c7 (patch)
tree2cb3f940e185b209cf63b2670567aad9946c8cd9 /media-sound
downloadunderlay-62fc0e82f038e1f8c1c434e1fb39c45b8f2fd0c7.tar.gz
underlay-62fc0e82f038e1f8c1c434e1fb39c45b8f2fd0c7.tar.bz2
underlay-62fc0e82f038e1f8c1c434e1fb39c45b8f2fd0c7.zip
first commit
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/ardour-irc/ChangeLog0
-rw-r--r--media-sound/ardour-irc/Manifest7
-rw-r--r--media-sound/ardour-irc/ardour-irc-0.21.ebuild53
-rw-r--r--media-sound/ardour-irc/metadata.xml10
4 files changed, 70 insertions, 0 deletions
diff --git a/media-sound/ardour-irc/ChangeLog b/media-sound/ardour-irc/ChangeLog
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/media-sound/ardour-irc/ChangeLog
diff --git a/media-sound/ardour-irc/Manifest b/media-sound/ardour-irc/Manifest
new file mode 100644
index 0000000..aae3d78
--- /dev/null
+++ b/media-sound/ardour-irc/Manifest
@@ -0,0 +1,7 @@
+AUX Irc.pm 4985 RMD160 19707d3c8203053f37e52e45652703b9542d9513 SHA1 ba16b77cd170d6a995f1fc39375d06b0880aefb2 SHA256 b0cd1f929c192211148b46df9ca6c44987692974b5bb96fbe21e3ac30c224b9e
+AUX aircd 1444 RMD160 853f57693505f56d120d4c10569ab5ee290eddb4 SHA1 79d3f3a7de3d9cadfa43ec124561b28365492af4 SHA256 cad36f3ac0ae143e4c191bda2a5f67887e50927c5c63c61c6eb0d663b311d513
+AUX lirc.conf 3735 RMD160 311a699da99604c5aba4c28e8a6cae3dfd030fc1 SHA1 32de7b8cef92d0873ffa279680b31c49cc192439 SHA256 421a6f5040b2cf732b00a13efedccddb333ee749e3d8d760dc55a98b22e5b3b5
+AUX lirc.conf-vdomate 1535 RMD160 f74e6745ead8578e4264cf7e17174a8f1b3295e9 SHA1 31ff3f530c0d1500dde2d403923e0f6310bd84a3 SHA256 3e1f217ab644d19d860428c34f86074bb883cb860f89caa86f5219eb9b3cb217
+EBUILD ardour-irc-0.20.ebuild 1584 RMD160 127f9fbe8502ecf55cdd676a8e9684062ac92745 SHA1 eacb56b686ffd22d9c472f460aed5299d0c4b8b9 SHA256 641cdb8d848adfb48c135e3d64ea62c6a9946e0e5ed3acd4a06c3cd8b7c9e002
+MISC ChangeLog 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+MISC metadata.xml 408 RMD160 0e97ac4b1ef6ed947e7f278d6860018201c0fb62 SHA1 1821db0146567443c07b707d7d2a2d7e451d841a SHA256 09ff29334bf978d58786f938e4f19a4030aca5dbdc65b3b6fca94245600c5203
diff --git a/media-sound/ardour-irc/ardour-irc-0.21.ebuild b/media-sound/ardour-irc/ardour-irc-0.21.ebuild
new file mode 100644
index 0000000..1894bf4
--- /dev/null
+++ b/media-sound/ardour-irc/ardour-irc-0.21.ebuild
@@ -0,0 +1,53 @@
+EAPI=2
+DESCRIPTION="IR remote control for Ardour"
+HOMEPAGE=""
+SRC_URI=""
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="x86 and64"
+IUSE=""
+
+RDEPEND="dev-perl/Class-Accessor
+ dev-perl/File-Path-Expand
+ dev-perl/Lirc-Client
+ dev-perl/Audio-Ardour-Irc
+ dev-lang/perl
+ app-misc/lirc"
+
+DEPEND="${RDEPEND}"
+
+confdir=/etc/ardour-irc/
+
+src_install() {
+ insinto /usr/bin/ || die "out of cheese error 0"
+ doins ${FILESDIR}"/aircd" || die "out of cheese error 1"
+ dodir $confdir || die "out of cheese error 2"
+ insinto $confdir || die "out of cheese error 3"
+ doins ${FILESDIR}"/lirc.conf" || die "out of cheese error 4"
+ doins ${FILESDIR}"/lirc.conf-vdomate" || die "out of cheese error 5"
+
+ #!! perl version dependency...
+ insinto /usr/lib/perl5/vendor_perl/5.12.2/Audio/Ardour/ || die "out of cheese error 0"
+ doins ${FILESDIR}"/Irc.pm" || die "out of cheese error 1"
+}
+
+# /usr/portage/distfiles/svn-src/ardour/2.0-ongoing/libs/ardour/osc.cc
+
+pkg_postinst() {
+ chmod +x /usr/bin/acird
+ elog ""
+ elog "(1) See http://en.gentoo-wiki.com/wiki/LIRC for info on setting up LIRC."
+ elog ""
+ elog "(2) You need to create a valid /etc/ardour-controllers/lirc.conf for your remote."
+ elog " Instructions are in the file."
+ elog ""
+ elog "(3) OSC is not enabled by default in Ardour - see menu: Options/Misc Options."
+ elog ""
+ elog "(4) Start the Ardour-Lirc daemon from the command line:"
+ elog ""
+ elog " $ aircd"
+ elog ""
+ elog " ...Ardour will now be able to hear commands from your remote."
+ elog ""
+}
+
diff --git a/media-sound/ardour-irc/metadata.xml b/media-sound/ardour-irc/metadata.xml
new file mode 100644
index 0000000..7605278
--- /dev/null
+++ b/media-sound/ardour-irc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>underlay</herd>
+<maintainer>
+ <email>airc@aperiplus.co.uk</email>
+ <description>Ardour Infra Red Control</description>
+</maintainer>
+<longdescription>Full OSC control of the Ardour DAW via infra-red remote control devices (such as a TV remote).</longdescription>
+</pkgmetadata>