summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-15 21:13:25 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-15 21:51:10 +0200
commitb7b83dde43cb42c79f8e23b8cbcd7ae97e2398d4 (patch)
tree0cbb39fddc909282a601bd6a537ec4940b8fb761
parentsys-apps/systemd-26: USE EAPI=4, as in the mgorny overlay (diff)
downloadsystemd-b7b83dde43cb42c79f8e23b8cbcd7ae97e2398d4.tar.gz
systemd-b7b83dde43cb42c79f8e23b8cbcd7ae97e2398d4.tar.bz2
systemd-b7b83dde43cb42c79f8e23b8cbcd7ae97e2398d4.zip
sys-apps/systemd-26: Add check for uevent helper
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-26.ebuild17
2 files changed, 18 insertions, 1 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 2f68152..6d4bf64 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1,4 +1,4 @@
DIST systemd-26.tar.bz2 791117 RMD160 06836ca8daf0c5ebc113940357289348561dac56 SHA1 901486904aeb1d8a3ae20e5971afd9b42b847450 SHA256 d7a222c09cdb0a9eebe97c7c499c458cc29ef8b3b2d0ca79bb949b2fd3d077d3
-EBUILD systemd-26.ebuild 3781 RMD160 966864aeeb17af70c861f1ad092e17bef2c5a430 SHA1 55da6ece8e240894f7b42a7e91e367696ed25e91 SHA256 e8df069fc8004d7997d2b29846ee38d1a057ecc9b02d7a359ea206eefd735e0f
+EBUILD systemd-26.ebuild 4236 RMD160 a7bdee3b9cadc269b6849229768b068f8f346f39 SHA1 ff30a7f5eac8d79fe6c1306a28d6e40a47d39370 SHA256 994bf8838bd831476181bd023a2b1c9b038cb318c4b70a8bdf49e681987ad5cb
EBUILD systemd-9999.ebuild 3609 RMD160 b01d998c48ad0cb5e851cc6e4f85a876867920e4 SHA1 61b2d74cc54d7b00af725c3275fd0d4f4d070761 SHA256 52bdb7d785a54b3fcb16156ba46845cbc5806942a9972d8b90d487c1949b03a3
MISC metadata.xml 737 RMD160 cdd440f38c039bfa7967fd713ef238588c2e1fb4 SHA1 1dea5e1d1e388bf43131297667bb4dbba10e65dd SHA256 042b1b68c02c274920954280705e21c2ca2ef5eece3229aab03d8dd43e06422d
diff --git a/sys-apps/systemd/systemd-26.ebuild b/sys-apps/systemd/systemd-26.ebuild
index 37e1980..339014b 100644
--- a/sys-apps/systemd/systemd-26.ebuild
+++ b/sys-apps/systemd/systemd-26.ebuild
@@ -39,9 +39,26 @@ DEPEND="${COMMON_DEPEND}
gtk? ( dev-lang/vala:${VALASLOT} )
>=sys-kernel/linux-headers-${MINKV}"
+check_no_uevent_hotplug_helper() {
+ local path
+ if linux_config_exists; then
+ path="$(linux_chkconfig_string UEVENT_HELPER_PATH)"
+ path="${path#\"}"
+ path="${path%\"}"
+ path="${path#\'}"
+ path="${path%\'}"
+ if test "${path}" != ""; then
+ qewarn "The kernel should be configured with"
+ qewarn "CONFIG_UEVENT_HELPER_PATH=\"\". Also, be sure to check"
+ qewarn "that /proc/sys/kernel/hotplug is empty."
+ fi
+ fi
+}
+
pkg_pretend() {
local CONFIG_CHECK="AUTOFS4_FS CGROUPS DEVTMPFS ~FANOTIFY ~IPV6"
linux-info_pkg_setup
+ check_no_uevent_hotplug_helper
kernel_is -ge ${MINKV//./ } || die "Kernel version at least ${MINKV} required"
}