summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-21 18:10:37 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-21 18:10:37 +0200
commit1ef940193c3e27605c9c7c8729e18102ea72dc66 (patch)
tree8545536d07d59c6317a6338787be1d027c326855
parentnet-dns/dnsmasq-2.57: Enable socket activation with systemd (diff)
downloadsystemd-1ef940193c3e27605c9c7c8729e18102ea72dc66.tar.gz
systemd-1ef940193c3e27605c9c7c8729e18102ea72dc66.tar.bz2
systemd-1ef940193c3e27605c9c7c8729e18102ea72dc66.zip
sys-apps/systemd-9999: Synchronize with v27 ebuild (add plymouth)
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-9999.ebuild53
2 files changed, 29 insertions, 26 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 2c09cf0..43ff65d 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -2,5 +2,5 @@ DIST systemd-26.tar.bz2 791117 RMD160 06836ca8daf0c5ebc113940357289348561dac56 S
DIST systemd-27.tar.bz2 809898 RMD160 bd9a2b0c065ff7d07e0fb5d0346ab9e355aaa6cf SHA1 2ccd50681a52ae5de5e5c5f1c3fc9233dfb26ad1 SHA256 3a8d978721a404b25df6a59dc666cf30a02f14d3c680c4f8c3a91e68a9407e53
EBUILD systemd-26.ebuild 4327 RMD160 d26de8d5b632a0c96b2dc19441d0d0d57bbfa2da SHA1 188fa736286c9bbc48147b732512243ed0e9a60d SHA256 0499bf01d2e23cf5106139597d0d2eec54625463da808285f9562dc7a6c735e1
EBUILD systemd-27.ebuild 4348 RMD160 9ad9e796ba8ffacf398e3345fddb51f4d652dfa6 SHA1 8f6d29a16d6a5f07bc22561a21c22023e22efe31 SHA256 50ef6b10292843bad29704a2ba0f1074ce373339f53c1f73710831261f1104ef
-EBUILD systemd-9999.ebuild 4215 RMD160 a7fda5c858136bd474c2a23fd5c630e84d6f412d SHA1 75eb64200629c890a8cdd554b58c57e06493d4ca SHA256 da9533edb1b2c531692c6d4a3b03e2b46ec82fb2fedbabeb870ac85609c711a5
+EBUILD systemd-9999.ebuild 4323 RMD160 0de7e66f4400b2be9275baa75206882f066537b3 SHA1 44ce1b98156c7f2c7aea73a1fdc88ef17fb708b8 SHA256 086934128a2d13a1959114a0fa42ae5d837ac80c3355b371e77c3ba38acff807
MISC metadata.xml 737 RMD160 cdd440f38c039bfa7967fd713ef238588c2e1fb4 SHA1 1dea5e1d1e388bf43131297667bb4dbba10e65dd SHA256 042b1b68c02c274920954280705e21c2ca2ef5eece3229aab03d8dd43e06422d
diff --git a/sys-apps/systemd/systemd-9999.ebuild b/sys-apps/systemd/systemd-9999.ebuild
index 26cf3b0..22e6597 100644
--- a/sys-apps/systemd/systemd-9999.ebuild
+++ b/sys-apps/systemd/systemd-9999.ebuild
@@ -14,7 +14,7 @@ EGIT_BRANCH="master"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="audit gtk pam selinux sysv +tcpwrap"
+IUSE="audit gtk pam plymouth selinux +tcpwrap"
COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
sys-libs/libcap
@@ -28,7 +28,8 @@ COMMON_DEPEND=">=sys-apps/dbus-1.4.8-r1
pam? ( virtual/pam )
selinux? ( sys-libs/libselinux )
tcpwrap? ( sys-apps/tcp-wrappers )
- >=sys-apps/util-linux-2.19"
+ >=sys-apps/util-linux-2.19
+ plymouth? ( >=sys-boot/plymouth-0.8.4 )"
# Vala-0.10 doesn't work with libnotify 0.7.1
VALASLOT="0.12"
@@ -84,32 +85,18 @@ src_configure() {
$(use_enable tcpwrap)
"
- if use sysv; then
- myconf="
- ${myconf}
- --with-sysvinit-path=/etc/init.d
- --with-sysvrcd-path=/etc
- "
- else
- myconf="
- ${myconf}
- --with-sysvinit-path=
- --with-sysvrcd-path=
- "
- fi
+ use gtk && export VALAC="$(type -p valac-${VALASLOT})"
- if use gtk; then
- export VALAC="$(type -p valac-${VALASLOT})"
- fi
+ use plymouth && export have_plymouth=1
econf ${myconf}
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
- dodoc "${D}"/usr/share/doc/systemd/* &&
- rm -r "${D}"/usr/share/doc/systemd
+ dodoc "${D}"/usr/share/doc/systemd/*
+ rm -rf "${D}"/usr/share/doc/systemd
cd "${D}"/usr/share/man/man8/
for i in halt poweroff reboot runlevel shutdown telinit; do
@@ -124,6 +111,7 @@ check_mtab_is_symlink() {
ewarn "${ROOT}etc/mtab must be a symlink to ${ROOT}proc/self/mounts!"
ewarn "To correct that, execute"
ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ elog
fi
}
@@ -132,20 +120,33 @@ systemd_machine_id_setup() {
if ! "${ROOT}"bin/systemd-machine-id-setup; then
ewarn "Setting up /etc/machine-id failed, to fix it please see"
ewarn " http://lists.freedesktop.org/archives/dbus/2011-March/014187.html"
+ elog
elif test ! -L "${ROOT}"var/lib/dbus/machine-id; then
# This should be fixed in the dbus ebuild, but we warn about it here.
ewarn "${ROOT}var/lib/dbus/machine-id ideally should be a symlink to"
ewarn "${ROOT}etc/machine-id to make it clear that they have the same"
ewarn "content."
+ elog
+ else
+ einfo
fi
}
check_var_run_is_symlink() {
if test ! -L "${ROOT}"var/run; then
- einfo "${ROOT}var/run should be a symlink to ${ROOT}run. This is not"
- einfo "trivial to change, and there is no hurry as it is currently"
- einfo "bind-mounted at boot-time. You may be able to create the"
- einfo "symlink by lazily unmounting ${ROOT}var/run first."
+ elog "${ROOT}var/run should be a symlink to ${ROOT}run. This is not"
+ elog "trivial to change, and there is no hurry as it is currently"
+ elog "bind-mounted at boot-time. You may be able to create the"
+ elog "symlink by lazily unmounting ${ROOT}var/run first."
+ elog
+ fi
+}
+
+check_var_lock_is_symlink() {
+ if test ! -L "${ROOT}"var/lock; then
+ elog "${ROOT}var/lock should be a symlink to ${ROOT}run/lock, see"
+ elog " https://lwn.net/Articles/436012/"
+ elog
fi
}
@@ -153,6 +154,7 @@ pkg_postinst() {
check_mtab_is_symlink
systemd_machine_id_setup
check_var_run_is_symlink
+ check_var_lock_is_symlink
# Inform user about extra configuration
elog "You may need to perform some additional configuration for some"
@@ -160,6 +162,7 @@ pkg_postinst() {
elog "handling tmpfiles:"
elog " $ man modules-load.d"
elog " $ man tmpfiles.d"
+ elog
ewarn "This is a work-in-progress ebuild. You may brick your system. Have fun!"
}