aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2016-02-09 23:35:54 +0000
committerStuart Shelton <stuart@shelton.me>2016-02-09 23:35:54 +0000
commit5d80ebb5fc455eb0f9525de113c121a67683cc7a (patch)
tree4251aa196632052aa9a499eebf899d92a938b667 /www-servers
parentUpdate sys-fs/mdadm-3.4 (diff)
downloadsrcshelton-5d80ebb5fc455eb0f9525de113c121a67683cc7a.tar.gz
srcshelton-5d80ebb5fc455eb0f9525de113c121a67683cc7a.tar.bz2
srcshelton-5d80ebb5fc455eb0f9525de113c121a67683cc7a.zip
Add www-servers/3dm2-10.2.2.1, update README.md
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/3dm2/3dm2-10.2.2.1.ebuild140
-rw-r--r--www-servers/3dm2/Manifest4
-rw-r--r--www-servers/3dm2/files/3dm2.835
-rw-r--r--www-servers/3dm2/files/3dm2.initd11
4 files changed, 190 insertions, 0 deletions
diff --git a/www-servers/3dm2/3dm2-10.2.2.1.ebuild b/www-servers/3dm2/3dm2-10.2.2.1.ebuild
new file mode 100644
index 00000000..04b27a24
--- /dev/null
+++ b/www-servers/3dm2/3dm2-10.2.2.1.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+case "${PV//./-}" in
+ 10-2-2-1)
+ CV="9.5.5.1"
+ ;;
+esac
+
+DESCRIPTION="3ware 3DM2 CLI Linux from the 10.2.2.1/9.5.5.1 code set 8xxx/95xx/96xx/97xx"
+HOMEPAGE="http://www.avagotech.com/support/download-search"
+SRC_URI="http://docs.avagotech.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/3DM2_CLI-linux_${PV//./-}_${CV//./-}.zip"
+RELNOTES="http://www.lsi.com/downloads/Public/SATA/SATA%20Common%20Files/${PV}_Release_Notes.pdf"
+
+# Note: 3ware gave permission to redistribute the binaries before:
+# Ref: https://bugs.gentoo.org/show_bug.cgi?id=60690#c106
+#
+# Please note that the LSI-tw_cli license does allow redistribution, despite
+# being a EULA:
+# 2. Grant of Rights
+# 2.1 LSI Binary Code. Subject to the terms of this Agreement, LSI grants
+# to Licensee a non-exclusive, world-wide, revocable (for breach in
+# accordance with Section 7), non-transferable limited license, without
+# the right to sublicense except as expressly provided herein, solely to:
+# (c) Distribute the LSI Binary Code as incorporated in Licensee's
+# Products or for use with LSI Devices to its Subsequent Users;
+# (d) Distribute the Explanatory Materials related to LSI Binary Code only
+# for use with LSI Devices;
+#
+# 3. License Restrictions
+# 3.1. LSI Binary Code. The Licenses granted in Section 2.1 for LSI Binary
+# Code and related Explanatory Materials are subject to the following
+# restrictions:
+# (a) Licensee shall not use the LSI Binary Code and related Explanatory
+# Materials for any purpose other than as expressly provided in Article 2;
+# (b) Licensee shall reproduce all copyright notices and other proprietary
+# markings or legends contained within or on the LSI Binary Code and
+# related Explanatory Materials on any copies it makes; and
+LICENSE="LSI-tw_cli"
+SLOT="0"
+
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/3ware/3DM2/3dm2"
+
+# binary packages
+DEPEND="app-arch/unzip
+ app-arch/tar"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ default_src_unpack
+ tar -xzpf tdmCliLnx.tgz || die "Embedded unpack failed: ${?}"
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^EmailEnable /s/ .*$/ 1/' \
+ -e '/^EmailSender /s/ .*$/ 3dm2/' \
+ -e '/^EmailServer /s/ .*$/ localhost/' \
+ -e '/^EmailRecipient /s/ .*$/ root/' \
+ -e '/^RemoteAccess /s/ .*$/ 0/' \
+ 3dm2.conf
+}
+
+src_install() {
+ if false; then
+ # Traditional 3ware filesystem layout
+ dodir /opt/3ware/3DM2{,/msg,/help}
+ exeinto /opt/3ware/3DM2
+ case ${ARCH} in
+ amd64)
+ newexe 3dm2u.x86_64 3dm2
+ ;;
+ x86)
+ newexe 3dm2u.x86 3dm2
+ ;;
+ esac
+ dosym /opt/3ware/3DM2/3dm2 /usr/sbin/3dm2
+
+ tar -xzpf tdm2Msg.tgz -C "${ED}"/opt/3ware/3DM2/msg
+ tar -xzpf tdm2Help.tgz -C "${ED}"/opt/3ware/3DM2/help
+ else
+ # Modern layout
+ case ${ARCH} in
+ amd64)
+ newsbin 3dm2u.x86_64 3dm2
+ ;;
+ x86)
+ newsbin 3dm2u.x86 3dm2
+ ;;
+ esac
+
+ tar -xzpf tdm2Msg.tgz
+ dodir /usr/share/${PN}/msg
+ insinto /usr/share/${PN}/msg
+ doins tdm_msg_en tw_msg_en
+
+ mkdir html
+ tar -xzpf tdm2Help.tgz -C html
+ dodoc -r html
+
+ sed -i \
+ -e "/^MsgPath /s| .*$| /usr/share/${PN}/msg|" \
+ -e "/^Help /s| .*$| /usr/share/doc/${PF}/html|" \
+ 3dm2.conf
+ fi
+
+ dodir /etc/3dm2
+ insinto /etc/3dm2
+ doins logo.gif
+ insopts "-m0600"
+ doins 3dm2.conf
+
+ doman "${FILESDIR}"/"${PN}".8
+
+ newinitd "${FILESDIR}"/"${PN}".initd "${PN}"
+}
+
+pkg_postinst() {
+ elog "3DM2 listens on https://127.0.0.1:888/ by default."
+ ewarn "For security reasons, only local connections are allowed by default."
+ elog "This behavior can be modified by setting 'RemoteAccess 1' in"
+ elog "/etc/3dm2/3dm2.conf and restarting the service."
+ elog
+ ewarn "The default passwords for both user and administrator are '3ware'."
+ eerror "PLEASE CHANGE THESE PASSWORDS *BEFORE* ENABLING REMOTE ACCESS"
+ elog
+ elog "Release notes for this version are available at:"
+ elog "${RELNOTES}"
+}
diff --git a/www-servers/3dm2/Manifest b/www-servers/3dm2/Manifest
new file mode 100644
index 00000000..d9595a6b
--- /dev/null
+++ b/www-servers/3dm2/Manifest
@@ -0,0 +1,4 @@
+AUX 3dm2.8 1059 SHA256 d405e764be67ea0ffb5a3f6b6b3832f8a61d9161da704798853b7835fef1882c SHA512 377f63366f3f045afd9455142cfe4cca4c3dc907a4e789d3e308c182064e27dd5ea7f68f7fe65f8febbc5c860fbe0fbe3dc5e8fe1c8ace19d425beac74d7f8da WHIRLPOOL 4e503095d30883691d7c55baa2433973a3bdf058cbdc5597a3a4cdf0b98280597b6e4c8671685cd826b6de03b6e8b39ce475b8990ee8d4bbc34e48198668f967
+AUX 3dm2.initd 242 SHA256 753ffa741dad09149209f3e54803ff5c9d23398c28658489dc099ac384734e0a SHA512 c39fb66a4568026335f49085041cfe7d5efcdd5243a957abb358da2e56736dc393846cd746af28fa6ba9e74232132aa3e181866416e87a6c044e9458df25a222 WHIRLPOOL be4503a8deda1a383ebb8fd07d9b8daabbaf1e5c73d95e510b6c86ac561be11d3930af7d03b7e50bf16ce7cf74f35ee229f6ddc336545a37316597e34f111a8a
+DIST 3DM2_CLI-linux_10-2-2-1_9-5-5-1.zip 10483242 SHA256 5354dd539d01163ee6d371da1bd595157dc6db8bfe0907dbb2b920d88cd627a9 SHA512 47cd7493084520c6b8c8da1d83b14f3943e239883ae72ce4a4d7cbb4496bb59e4feff6c295af1d6d43ef038ac483e907639407feb15b6f0427190e4389efbb07 WHIRLPOOL 7e7fedfebfbb73eb333881e1b75eea108c23751631b8f6225dc890d23fc66626cd1124699f9c5880b100eaa34d9d1bd06eb7f68fac6845e781519b978b31c457
+EBUILD 3dm2-10.2.2.1.ebuild 4089 SHA256 3cc6578862377bf30bdcef63ec8ba7bc921888b49f51268a6239e28505df5269 SHA512 1867b85a5ad97bb0b2f01a33bb9f15d9bef950cdbc959b58a13cefeac95db3c2cb105117f5e9ab2867a32c7426cc8e783f36d2f9f0a4d5800dcec8862cf88f9e WHIRLPOOL 47c2ef0afa5258a204727049bc50980b3af531865460cf2c5e7c262c60beb011ced2a136115cb663d70a2255d6b0cbb7428bb66c64f242231cc9b0dd3d06a519
diff --git a/www-servers/3dm2/files/3dm2.8 b/www-servers/3dm2/files/3dm2.8
new file mode 100644
index 00000000..44376714
--- /dev/null
+++ b/www-servers/3dm2/files/3dm2.8
@@ -0,0 +1,35 @@
+.TH 3DM2 8 "2012-01-30" "2.11.00.019+10.2.1" "3Ware Disk Management"
+
+.SH NAME
+3dm2 \- 3ware 3DM 2 Disk Management Utility.
+
+.SH SYNOPSIS
+.B 3dm2
+
+.SH DESCRIPTION
+3ware Disk Manager 2 (3DM 2), allows you to view the status of and manage 3ware
+RAID controllers and associated drives. 3DM 2 runs as a daemon. When it is
+running, you can use your browser to view status and perform administrative
+tasks locally or remotely.
+.PP
+This version of 3DM2 supports all known 3Ware controllers.
+
+.SH OPTIONS
+.B 3dm2
+has no options.
+
+.SH CONFIGURATION
+In /etc/3dm2/3dm2.conf, the following defaults are set:
+.TP
+3DM 2 is listening on <https://localhost:888/>.
+.TP
+Default password for both the user and the administrator is '3ware'.
+.TP
+Remote access is disabled for security reasons (change 'RemoteAccess 0' to 'RemoteAcces 1' to enable it and restart the 3dm2 daemon).
+.PP
+
+.SH AUTHOR
+3dm2 was written by the AMCC 3DM 2 Development Team.
+.PP
+This manual page was written by Jonas Genannt <jonas.genannt@capi2name.de> for
+the Debian project (but may be used by others).
diff --git a/www-servers/3dm2/files/3dm2.initd b/www-servers/3dm2/files/3dm2.initd
new file mode 100644
index 00000000..995e7041
--- /dev/null
+++ b/www-servers/3dm2/files/3dm2.initd
@@ -0,0 +1,11 @@
+#!/sbin/runscript
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/libexec/3dm2"
+description="3ware Disk Manager"
+
+depend() {
+ need localmount
+ need net
+}