aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2018-04-27 21:28:40 +0100
committerStuart Shelton <stuart@shelton.me>2018-04-27 21:28:40 +0100
commit6219d3d45f531cfa0dd838ce27b0ef2ed54439ad (patch)
tree489ac4c3bbc96dbb612b730742c69ca0e81edac5 /dev-libs
parentRemove obsolete python ebuilds with no remaining upstream downloads (diff)
downloadsrcshelton-6219d3d45f531cfa0dd838ce27b0ef2ed54439ad.tar.gz
srcshelton-6219d3d45f531cfa0dd838ce27b0ef2ed54439ad.tar.bz2
srcshelton-6219d3d45f531cfa0dd838ce27b0ef2ed54439ad.zip
Remove obsolete jemalloc ebuilds with no remaining upstream downloads
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/jemalloc/files/jemalloc-4.1-fix_stack_corruption.patch70
-rw-r--r--dev-libs/jemalloc/jemalloc-4.0.4.ebuild50
-rw-r--r--dev-libs/jemalloc/jemalloc-4.1.0.ebuild48
-rw-r--r--dev-libs/jemalloc/jemalloc-4.2.0.ebuild47
-rw-r--r--dev-libs/jemalloc/jemalloc-4.2.1.ebuild47
5 files changed, 0 insertions, 262 deletions
diff --git a/dev-libs/jemalloc/files/jemalloc-4.1-fix_stack_corruption.patch b/dev-libs/jemalloc/files/jemalloc-4.1-fix_stack_corruption.patch
deleted file mode 100644
index f36c1886..00000000
--- a/dev-libs/jemalloc/files/jemalloc-4.1-fix_stack_corruption.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 33184bf69813087bf1885b0993685f9d03320c69 Mon Sep 17 00:00:00 2001
-From: Dmitri Smirnov <dmitrism@microsoft.com>
-Date: Mon, 29 Feb 2016 14:30:19 -0800
-Subject: [PATCH] Fix stack corruption and uninitialized var warning
-
-Stack corruption happens in x64 bit
-
-This resolves #347.
----
- src/arena.c | 2 +-
- test/unit/hash.c | 13 +++++++------
- 2 files changed, 8 insertions(+), 7 deletions(-)
-
-diff --git a/src/arena.c b/src/arena.c
-index 99e20fd..965c0fe 100644
---- a/src/arena.c
-+++ b/src/arena.c
-@@ -2423,7 +2423,7 @@ arena_malloc_large(tsd_t *tsd, arena_t *arena, szind_t binind, bool zero)
- uintptr_t random_offset;
- arena_run_t *run;
- arena_chunk_map_misc_t *miscelm;
-- UNUSED bool idump;
-+ UNUSED bool idump JEMALLOC_CC_SILENCE_INIT(false);
-
- /* Large allocation. */
- usize = index2size(binind);
-diff --git a/test/unit/hash.c b/test/unit/hash.c
-index f50ba81..010c9d7 100644
---- a/test/unit/hash.c
-+++ b/test/unit/hash.c
-@@ -64,14 +64,15 @@ static void
- hash_variant_verify_key(hash_variant_t variant, uint8_t *key)
- {
- const int hashbytes = hash_variant_bits(variant) / 8;
-- VARIABLE_ARRAY(uint8_t, hashes, hashbytes * 256);
-+ const int hashes_size = hashbytes * 256;
-+ VARIABLE_ARRAY(uint8_t, hashes, hashes_size);
- VARIABLE_ARRAY(uint8_t, final, hashbytes);
- unsigned i;
- uint32_t computed, expected;
-
- memset(key, 0, KEY_SIZE);
-- memset(hashes, 0, sizeof(hashes));
-- memset(final, 0, sizeof(final));
-+ memset(hashes, 0, hashes_size);
-+ memset(final, 0, hashbytes);
-
- /*
- * Hash keys of the form {0}, {0,1}, {0,1,2}, ..., {0,1,...,255} as the
-@@ -102,17 +103,17 @@ hash_variant_verify_key(hash_variant_t variant, uint8_t *key)
- /* Hash the result array. */
- switch (variant) {
- case hash_variant_x86_32: {
-- uint32_t out = hash_x86_32(hashes, hashbytes*256, 0);
-+ uint32_t out = hash_x86_32(hashes, hashes_size, 0);
- memcpy(final, &out, sizeof(out));
- break;
- } case hash_variant_x86_128: {
- uint64_t out[2];
-- hash_x86_128(hashes, hashbytes*256, 0, out);
-+ hash_x86_128(hashes, hashes_size, 0, out);
- memcpy(final, out, sizeof(out));
- break;
- } case hash_variant_x64_128: {
- uint64_t out[2];
-- hash_x64_128(hashes, hashbytes*256, 0, out);
-+ hash_x64_128(hashes, hashes_size, 0, out);
- memcpy(final, out, sizeof(out));
- break;
- } default: not_reached();
diff --git a/dev-libs/jemalloc/jemalloc-4.0.4.ebuild b/dev-libs/jemalloc/jemalloc-4.0.4.ebuild
deleted file mode 100644
index 63af6e05..00000000
--- a/dev-libs/jemalloc/jemalloc-4.0.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: 5cbaa8d4cc7f4c6123d299d03ffd2169d839656b $
-
-EAPI=5
-
-inherit autotools-multilib eutils
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://www.canonware.com/jemalloc/"
-SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~x64-macos"
-IUSE="debug static-libs stats"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
- "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
-)
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
-# but jemalloc doesn't implement them in its configure; need this here to
-# supress the warnings until automagic is removed from the eclass
-QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
-src_configure() {
- myeconfargs=(
- $(use_enable debug)
- $(use_enable stats)
- )
- autotools-multilib_src_configure
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-src_install() {
- autotools-multilib_src_install
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- use static-libs || find "${ED}" -name '*.a' -delete
-}
diff --git a/dev-libs/jemalloc/jemalloc-4.1.0.ebuild b/dev-libs/jemalloc/jemalloc-4.1.0.ebuild
deleted file mode 100644
index 8624b0d4..00000000
--- a/dev-libs/jemalloc/jemalloc-4.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: a03d99d306d383d3ae9a43a20315449448fb6556 $
-
-EAPI=6
-
-inherit toolchain-funcs multilib-build
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://www.canonware.com/jemalloc/"
-SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="debug static-libs stats"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
- "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
- "${FILESDIR}/${PN}-4.1-fix_stack_corruption.patch"
-)
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
-# but jemalloc doesn't implement them in its configure; need this here to
-# supress the warnings until automagic is removed from the eclass
-QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable debug)
- $(use_enable stats)
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- use static-libs || find "${ED}" -name '*.a' -delete
-}
diff --git a/dev-libs/jemalloc/jemalloc-4.2.0.ebuild b/dev-libs/jemalloc/jemalloc-4.2.0.ebuild
deleted file mode 100644
index 8951d34d..00000000
--- a/dev-libs/jemalloc/jemalloc-4.2.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: 8c320ea1c37f32ac8644494e4f61a5b343e2d6cd $
-
-EAPI=6
-
-inherit toolchain-funcs multilib-build
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://www.canonware.com/jemalloc/"
-SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="debug static-libs stats"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
- "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
-)
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
-# but jemalloc doesn't implement them in its configure; need this here to
-# supress the warnings until automagic is removed from the eclass
-QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable debug)
- $(use_enable stats)
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- use static-libs || find "${ED}" -name '*.a' -delete
-}
diff --git a/dev-libs/jemalloc/jemalloc-4.2.1.ebuild b/dev-libs/jemalloc/jemalloc-4.2.1.ebuild
deleted file mode 100644
index 8951d34d..00000000
--- a/dev-libs/jemalloc/jemalloc-4.2.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id: 8c320ea1c37f32ac8644494e4f61a5b343e2d6cd $
-
-EAPI=6
-
-inherit toolchain-funcs multilib-build
-
-DESCRIPTION="Jemalloc is a general-purpose scalable concurrent allocator"
-HOMEPAGE="http://www.canonware.com/jemalloc/"
-SRC_URI="http://www.canonware.com/download/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="debug static-libs stats"
-HTML_DOCS=( doc/jemalloc.html )
-PATCHES=( "${FILESDIR}/${PN}-3.5.1-strip-optimization.patch"
- "${FILESDIR}/${PN}-3.5.1_fix_html_install.patch"
-)
-MULTILIB_WRAPPED_HEADERS=( /usr/include/jemalloc/jemalloc.h )
-# autotools-utils.eclass auto-adds configure options when static-libs is in IUSE
-# but jemalloc doesn't implement them in its configure; need this here to
-# supress the warnings until automagic is removed from the eclass
-QA_CONFIGURE_OPTIONS="--enable-static --disable-static --enable-shared --disable-shared"
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- $(use_enable debug)
- $(use_enable stats)
-}
-
-multilib_src_install() {
- # Copy man file which the Makefile looks for
- cp "${S}/doc/jemalloc.3" "${BUILD_DIR}/doc" || die
- emake DESTDIR="${D}" install
-}
-
-multilib_src_install_all() {
- if [[ ${CHOST} == *-darwin* ]] ; then
- # fixup install_name, #437362
- install_name_tool \
- -id "${EPREFIX}"/usr/$(get_libdir)/libjemalloc.2.dylib \
- "${ED}"/usr/$(get_libdir)/libjemalloc.2.dylib || die
- fi
- use static-libs || find "${ED}" -name '*.a' -delete
-}