aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2015-08-31 20:37:40 +0059
committerStuart Shelton <stuart@shelton.me>2015-08-31 20:37:40 +0059
commit689bf298c846a876ebfa93d0646e8f9a3980eb2e (patch)
treeefd64573f2a2c9c74250018d9090bb08309a00fd /app-emulation
parentAdd sys-kernel/raspberrypi-sources-4.1.9999, sys-kernel/raspberrypi-sources-4... (diff)
downloadsrcshelton-689bf298c846a876ebfa93d0646e8f9a3980eb2e.tar.gz
srcshelton-689bf298c846a876ebfa93d0646e8f9a3980eb2e.tar.bz2
srcshelton-689bf298c846a876ebfa93d0646e8f9a3980eb2e.zip
Update all ebulids and files with substituted git '$' values to enable tracking
Update ebulids as necessary to match new (and, retrieved via rsync, unversioned at a per-change level) upstream files
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker/Manifest2
-rw-r--r--app-emulation/docker/docker-9999.ebuild264
-rw-r--r--app-emulation/lxc/Manifest4
-rw-r--r--app-emulation/lxc/files/lxc.initd.32
-rw-r--r--app-emulation/lxc/lxc-1.0.6-r1.ebuild2
5 files changed, 159 insertions, 115 deletions
diff --git a/app-emulation/docker/Manifest b/app-emulation/docker/Manifest
index ff738e4e..23b6721b 100644
--- a/app-emulation/docker/Manifest
+++ b/app-emulation/docker/Manifest
@@ -5,4 +5,4 @@ DIST docker-0.11.1.zip 5057294 SHA256 b11458add04e0d50dece28e4919cc32cbc38e08f67
DIST docker-1.0.0.zip 8216390 SHA256 7552e1e02ed25c328c1c70820951fba144715bb3e2633d874f5635238745470c SHA512 4a39c84cbf6a62d930b5e0e6005fb5bc84c954789319edd6a199788e1185a014f570977cd728190e447196c70ca3710d1a4b049f9ec8099dbb6f7df26896b426 WHIRLPOOL a9dc0d0d9bec1465316c37280070740cb78f671b6610ac25605bd0f88823eed3e68443e020f2b77d3ca18f12e5d89887a95f0970d56b875c85988bc86afb801d
EBUILD docker-0.11.1.ebuild 5555 SHA256 68a0a3cf7cb6538698f3d48f72cec34913847677d79b0db1b0a12f19c4b7821c SHA512 7e624a8e59d98929d7d9a70866382d4fc0f10a10226c8fa75080ba344ee123d00f953c49f8cd6447ab15ade19825c1667526786610ce0883c5d61e9d48ee3259 WHIRLPOOL b59c2d6e38603dee853e17fc93799002b93cd3e1dc64b09d73134d666e5025806d69e706e6aa8b50598ba4b7869d29491a8e8060ed4b0550c6c117801f3d63e6
EBUILD docker-1.0.0.ebuild 5622 SHA256 a75ff4862df2bb08b364220264918404cb6b93504e5013361f40afaa65a193f2 SHA512 4431f72668c3377c81563a9bd29fff4e99fe5b5f9f2fff4e0be5a0e35f153f3af183ce7427f7c8244dd6b3d6ac3656ba816f99dcac89a7a706679f1cb3c6f1d0 WHIRLPOOL d3a74078cbb8f2d5e24319addf35a13eb2874e3b01bc2b1d6602b8ac46203188dba0b065ff4ee719480891c044a0e2aa63e1ca9ce4e35832d3985e6e66683c39
-EBUILD docker-9999.ebuild 5555 SHA256 68a0a3cf7cb6538698f3d48f72cec34913847677d79b0db1b0a12f19c4b7821c SHA512 7e624a8e59d98929d7d9a70866382d4fc0f10a10226c8fa75080ba344ee123d00f953c49f8cd6447ab15ade19825c1667526786610ce0883c5d61e9d48ee3259 WHIRLPOOL b59c2d6e38603dee853e17fc93799002b93cd3e1dc64b09d73134d666e5025806d69e706e6aa8b50598ba4b7869d29491a8e8060ed4b0550c6c117801f3d63e6
+EBUILD docker-9999.ebuild 7616 SHA256 a5545cc1ef946a072db72b20569070355392e4c61478f0158fc6f9de1e39fde5 SHA512 3abeb3418cdc1a36bbaecd25ab4fd131f83a03aef2b5e35b4dca959bce3690113a690e6313eff09f2791023b74adcf0734cf62a2b65b82d95c71470925217540 WHIRLPOOL 06a60b3863679a76c483c01598c7a8ba45fbc7d97fe7db29a424460d68df1e7b2e070b92ab2c55314c7908fcf3ff2537acbd980520a73a3e8cfc50cc91de7daf
diff --git a/app-emulation/docker/docker-9999.ebuild b/app-emulation/docker/docker-9999.ebuild
index d14a6ffc..3be39db2 100644
--- a/app-emulation/docker/docker-9999.ebuild
+++ b/app-emulation/docker/docker-9999.ebuild
@@ -1,125 +1,150 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/docker/docker-0.11.1.ebuild,v 1.1 2014/05/09 02:39:45 gregkh Exp $
+# $Id: 0fea9a31ac7ee226c59382e2a4c29ab01139314d $
EAPI=5
-DESCRIPTION="Docker complements kernel namespacing with a high-level API which operates at the process level."
-HOMEPAGE="https://www.docker.io/"
+EGO_PN="github.com/docker/docker"
-GITHUB_URI="github.com/dotcloud/docker"
-
-if [[ ${PV} == *9999 ]]; then
- SRC_URI=""
- EGIT_REPO_URI="git://${GITHUB_URI}.git"
- inherit git-2
- KEYWORDS=""
+if [[ ${PV} = *9999* ]]; then
+ # Docker cannot be fetched via "go get", thanks to autogenerated code
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
+ inherit git-r3
else
- SRC_URI="https://${GITHUB_URI}/archive/v${PV}.zip -> ${P}.zip"
- DOCKER_GITCOMMIT="fb99f99"
+ MY_PV="${PV/_/-}"
+ DOCKER_GITCOMMIT="d12ea79"
+ EGIT_COMMIT="v${MY_PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
[ "$DOCKER_GITCOMMIT" ] || die "DOCKER_GITCOMMIT must be added manually for each bump!"
+ inherit golang-vcs-snapshot
fi
+inherit bash-completion-r1 linux-info multilib systemd udev user
-inherit bash-completion-r1 linux-info systemd udev user
-
+DESCRIPTION="Docker complements kernel namespacing with a high-level API which operates at the process level"
+HOMEPAGE="https://dockerproject.org"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="aufs btrfs +contrib +device-mapper doc lxc systemd udev vim-syntax zsh-completion"
+IUSE="apparmor aufs btrfs +contrib +device-mapper doc experimental lxc overlay systemd udev vim-syntax zsh-completion"
-# TODO work with upstream to allow us to build without lvm2 installed if we have -device-mapper
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
CDEPEND="
>=dev-db/sqlite-3.7.9:3
device-mapper? (
- sys-fs/lvm2[thin]
+ >=sys-fs/lvm2-2.02.89[thin]
)
"
+
DEPEND="
${CDEPEND}
- >=dev-lang/go-1.2
+
+ dev-go/go-md2man
+
btrfs? (
- >=sys-fs/btrfs-progs-0.20
+ >=sys-fs/btrfs-progs-3.8
)
- dev-vcs/git
- dev-vcs/mercurial
"
+
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#runtime-dependencies
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#optional-dependencies
RDEPEND="
${CDEPEND}
+
!app-emulation/docker-bin
|| (
>=net-firewall/iptables-1.4
net-firewall/iptables-nftables
)
- lxc? (
- >=app-emulation/lxc-0.8
- )
+ sys-process/procps
>=dev-vcs/git-1.7
>=app-arch/xz-utils-4.9
- aufs? (
- || (
- sys-fs/aufs3
- sys-kernel/aufs-sources
- )
+
+ lxc? (
+ >=app-emulation/lxc-1.0.7
+ )
+
+ apparmor? (
+ sys-libs/libapparmor[static-libs]
)
"
-RESTRICT="strip"
+RESTRICT="installsources strip"
+
+# see "contrib/check-config.sh" from upstream's sources
+CONFIG_CHECK="
+ ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
+ ~MACVLAN ~VETH ~BRIDGE ~BRIDGE_NETFILTER
+ ~NF_NAT_IPV4 ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
+ ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK
+ ~NF_NAT ~NF_NAT_NEEDED
+
+ ~POSIX_MQUEUE
+
+ ~MEMCG_KMEM ~MEMCG_SWAP ~MEMCG_SWAP_ENABLED
+
+ ~BLK_CGROUP ~IOSCHED_CFQ
+ ~CGROUP_PERF
+ ~CGROUP_HUGETLB
+ ~NET_CLS_CGROUP
+ ~CFS_BANDWIDTH ~FAIR_GROUP_SCHED ~RT_GROUP_SCHED
+"
+
+ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
+ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
+ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
+
+ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
+ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
+ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
+ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
pkg_setup() {
- if kernel_is lt 3 8; then
+ if kernel_is lt 3 10; then
ewarn ""
- ewarn "Using Docker with kernels older than 3.8 is unstable and unsupported."
+ ewarn "Using Docker with kernels older than 3.10 is unstable and unsupported."
+ ewarn " - http://docs.docker.com/installation/binaries/#check-kernel-dependencies"
+ fi
+
+ # for where these kernel versions come from, see:
+ # https://www.google.com/search?q=945b2b2d259d1a4364a2799e80e8ff32f8c6ee6f+site%3Akernel.org%2Fpub%2Flinux%2Fkernel+file%3AChangeLog*
+ if ! {
+ kernel_is ge 3 16 \
+ || { kernel_is 3 15 && kernel_is ge 3 15 5; } \
+ || { kernel_is 3 14 && kernel_is ge 3 14 12; } \
+ || { kernel_is 3 12 && kernel_is ge 3 12 25; }
+ }; then
+ ewarn ""
+ ewarn "There is a serious Docker-related kernel panic that has been fixed in 3.16+"
+ ewarn " (and was backported to 3.15.5+, 3.14.12+, and 3.12.25+)"
ewarn ""
+ ewarn "See also https://github.com/docker/docker/issues/2960"
fi
- # many of these were borrowed from the app-emulation/lxc ebuild
- CONFIG_CHECK+="
- ~CGROUPS
- ~CGROUP_CPUACCT
- ~CGROUP_DEVICE
- ~CGROUP_SCHED
- ~CPUSETS
- ~MEMCG_SWAP
- ~RESOURCE_COUNTERS
-
- ~IPC_NS
- ~NAMESPACES
- ~PID_NS
-
- ~DEVPTS_MULTIPLE_INSTANCES
- ~MACVLAN
- ~NET_NS
- ~UTS_NS
- ~VETH
-
- ~!NETPRIO_CGROUP
- ~POSIX_MQUEUE
-
- ~BRIDGE
- ~IP_NF_TARGET_MASQUERADE
- ~NETFILTER_XT_MATCH_ADDRTYPE
- ~NETFILTER_XT_MATCH_CONNTRACK
- ~NF_NAT
- ~NF_NAT_NEEDED
-
- ~!GRKERNSEC_CHROOT_CAPS
- ~!GRKERNSEC_CHROOT_CHMOD
- ~!GRKERNSEC_CHROOT_DOUBLE
- ~!GRKERNSEC_CHROOT_MOUNT
- ~!GRKERNSEC_CHROOT_PIVOT
- "
-
- ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
-
- for c in GRKERNSEC_CHROOT_MOUNT GRKERNSEC_CHROOT_DOUBLE GRKERNSEC_CHROOT_PIVOT GRKERNSEC_CHROOT_CHMOD; do
- declare "ERROR_$c"="CONFIG_$c: see app-emulation/lxc postinst notes for why some GRSEC features make containers unusuable"
- done
+ if kernel_is le 3 18; then
+ CONFIG_CHECK+="
+ ~RESOURCE_COUNTERS
+ "
+ fi
+
+ if kernel_is le 3 13; then
+ CONFIG_CHECK+="
+ ~NETPRIO_CGROUP
+ "
+ else
+ CONFIG_CHECK+="
+ ~CGROUP_NET_PRIO
+ "
+ fi
if use aufs; then
CONFIG_CHECK+="
~AUFS_FS
+ ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
"
- ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs-sources are used"
+ ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs-sources are used instead of aufs4/aufs3"
fi
if use btrfs; then
@@ -130,24 +155,36 @@ pkg_setup() {
if use device-mapper; then
CONFIG_CHECK+="
- ~BLK_DEV_DM
- ~DM_THIN_PROVISIONING
- ~EXT4_FS
+ ~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
"
fi
- check_extra_config
+ if use overlay; then
+ CONFIG_CHECK+="
+ ~OVERLAY_FS ~EXT4_FS_SECURITY ~EXT4_FS_POSIX_ACL
+ "
+ fi
+
+ linux-info_pkg_setup
+
+ # create docker group for the code checking for it in /etc/group
+ enewgroup docker
+}
+
+src_prepare() {
+ cd "src/${EGO_PN}" || die
+ # allow user patches (use sparingly - upstream won't support them)
+ epatch_user
}
src_compile() {
- # if we treat them right, Docker's build scripts will set up a
- # reasonable GOPATH for us
- export AUTO_GOPATH=1
+ cd "src/${EGO_PN}" || die
+ export GOPATH="${WORKDIR}/${P}:${PWD}/vendor:$(get_golibdir_gopath)"
# setup CFLAGS and LDFLAGS for separate build target
# see https://github.com/tianon/docker-overlay/pull/10
export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="-L${ROOT}/usr/lib"
+ export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
# if we're building from a zip, we need the GITCOMMIT value
[ "$DOCKER_GITCOMMIT" ] && export DOCKER_GITCOMMIT
@@ -156,45 +193,53 @@ src_compile() {
sed -i "s/EXTLDFLAGS_STATIC='/EXTLDFLAGS_STATIC='-fno-PIC /" hack/make.sh || die
grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
- sed -i 's/LDFLAGS_STATIC_DOCKER="/LDFLAGS_STATIC_DOCKER="-extldflags -fno-PIC /' hack/make/dynbinary || die
+ sed -i "s/LDFLAGS_STATIC_DOCKER='/LDFLAGS_STATIC_DOCKER='-extldflags -fno-PIC /" hack/make/dynbinary || die
grep -q -- '-fno-PIC' hack/make/dynbinary || die 'hardened sed failed'
fi
# let's set up some optional features :)
export DOCKER_BUILDTAGS=''
- for gd in aufs btrfs device-mapper; do
+ for gd in aufs btrfs device-mapper overlay; do
if ! use $gd; then
DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
fi
done
+ if use apparmor; then
+ DOCKER_BUILDTAGS+=' apparmor'
+ fi
+
+ # https://github.com/docker/docker/pull/13338
+ if use experimental; then
+ export DOCKER_EXPERIMENTAL=1
+ else
+ unset DOCKER_EXPERIMENTAL
+ fi
+
# time to build!
- ./hack/make.sh dynbinary || die
+ ./hack/make.sh dynbinary || die 'dynbinary failed'
- # TODO pandoc the man pages using contrib/man/md/md2man-all.sh
+ # build the man pages too
+ ./man/md2man-all.sh || die "unable to generate man pages"
}
src_install() {
- VERSION=$(cat VERSION)
- newbin bundles/$VERSION/dynbinary/docker-$VERSION docker
+ cd "src/${EGO_PN}" || die
+ VERSION="$(cat VERSION)"
+ newbin "bundles/$VERSION/dynbinary/docker-$VERSION" docker
exeinto /usr/libexec/docker
- newexe bundles/$VERSION/dynbinary/dockerinit-$VERSION dockerinit
+ newexe "bundles/$VERSION/dynbinary/dockerinit-$VERSION" dockerinit
newinitd contrib/init/openrc/docker.initd docker
newconfd contrib/init/openrc/docker.confd docker
- use systemd && systemd_dounit contrib/init/systemd/docker.service
+ use systemd && systemd_dounit contrib/init/systemd/docker.{service,socket}
use udev && udev_dorules contrib/udev/*.rules
dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
- if use doc; then
- # TODO doman contrib/man/man*/*
-
- docompress -x /usr/share/doc/${PF}/md
- docinto md
- dodoc -r docs/sources/*
- fi
+ use doc && dodoc -r docs/*
+ doman man/man*/*
dobashcomp contrib/completion/bash/*
@@ -210,7 +255,7 @@ src_install() {
fi
if use contrib; then
- insinto /usr/share/${PN}/contrib
+ insinto "/usr/share/${PN}/contrib"
doins -r contrib/*
fi
}
@@ -218,19 +263,18 @@ src_install() {
pkg_postinst() {
use udev && udev_reload
- elog ""
- elog "To use docker, the docker daemon must be running as root. To automatically"
- elog "start the docker daemon at boot, add docker to the default runlevel:"
+ elog
+ elog "To use Docker, the Docker daemon must be running as root. To automatically"
+ elog "start the Docker daemon at boot, add Docker to the default runlevel:"
elog " rc-update add docker default"
if use systemd; then
elog "Similarly for systemd:"
elog " systemctl enable docker.service"
fi
- elog ""
-
- # create docker group if the code checking for it in /etc/group exists
- enewgroup docker
-
- elog "To use docker as a non-root user, add yourself to the docker group."
- elog ""
+ elog
+ elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
+ elog " usermod -aG docker youruser"
+ elog
}
+
+# vi: set diffopt=iwhite,filler:
diff --git a/app-emulation/lxc/Manifest b/app-emulation/lxc/Manifest
index 9e971771..aa86ead1 100644
--- a/app-emulation/lxc/Manifest
+++ b/app-emulation/lxc/Manifest
@@ -1,11 +1,11 @@
AUX lxc-1.0.6-bash-completion.patch 1341 SHA256 ddac7cc033a4029f8264d06978321bb33ef7c4fd34c9a44bb1acaaaf1c85d302 SHA512 56b00f77812c0600a8ff7557ef0acf7f50d37bb9f6e5b3641c9a218a53ac64a59785430d0775c1c7980ac39120a2544fd7c28cf39fefc07e7f1558f88b9b5917 WHIRLPOOL b3ff9a377d7d29fa76b6d547f2d1b1621c5ab52e972a9b52389c269f26ba9f43eae6a414db46135be84f1ed91ebea9d6d24cc25da11f493dc86fee088e90bfb4
AUX lxc.initd.2 3673 SHA256 bb7780168695e934549909c5c7baa7d6cdc92b0e19093a3d04a1313081a832e1 SHA512 25b0474d6f16fcede89a8e17518a658f810cb554eaef10aae3ce1fdd8c8640118aa6375cbee443f0b26e8086eb7c25375ceaaaf29a4110bd779f94b2f4b0d300 WHIRLPOOL 28f56d71b95b26c7f6ad5402a37413a973bc7bdf08fd3963ad192888ae1b49809a56c16009bc6049061d419ecffb1279e153e6ef5acbe06956efca154eae6a01
-AUX lxc.initd.3 4296 SHA256 82f19036252354e2d6ae75e8b266671e6cc9bf38a98cbf5db12da3851f02d15c SHA512 64f564cb8bd2ceea02749d0536436bc2fb313aa372cf35a4c70761d6738a3ceb9dea7e7d47ccda01b724c5a96637041347d0de7a368ccdf279ad9100983b581f WHIRLPOOL 8885f8a0acace114bddf8a9a842707dce896c5e631144824b9743539d2dfb4729aaaa4224f45e4d2b508329f7fd8cfca7821e8304b630d3b9b433bdab7c9a7ed
+AUX lxc.initd.3 4346 SHA256 3cd339c68119090ba9b27bb9247640c0de2496ce14a76a75138b9fffdbdde883 SHA512 7cb86844926d4c2d8550f28dcb87452fe9781f65f0c9ce34a2292454b4bd81eb608a72db81d0adf12573b603fcd34e5f2da012214f707bed12a0ff1612cce9a7 WHIRLPOOL a5957985e3a942d554e354337bdee2ac21e420b4b201cd9797c0ee7df832b4a5e45ebcbb1f28e10ae07cee39bf7e773b520e4da19e3766b427ce516cd953cea3
AUX lxc_at.service 232 SHA256 0aaf2f362b3ac6aa2b427d47ac4436d46387624b0d8bc4850c5d5b6a7d228711 SHA512 4c3bab4f2cc9aea8b0753dcaf2fd7ed5f1cd7d97d286d6204b2fc17505b6edaac2f536bbda5c1466856311d0e93d75de91dec51e9b0f665d67afedbf40c19170 WHIRLPOOL f6928b4b85e63c38295cabc651b7bd61d2b0bc69ff1850de7cfa8a4f40e4894d94264c262fec7d345488cace49c4283f932739313b975f6862c1aa0ef51e0652
DIST lxc-1.0.3.tar.gz 538073 SHA256 9fc4ac60a842058e4ad0fe6a281dc0079ee9830afa1852a10fa044219f2c6412 SHA512 95d7080cdb34776b601959bbc95572b1d6defeaec6820a38d9b09eb05bb43eaa4a2c4d9fae26f4d1a7ee13ad6cd104c36dd5cbe6ee5e44f274135e42370cc983 WHIRLPOOL 99324332f6d1f50dc3c0c9e54a565295b2186183f9e198418a8a891b799befebabf42784eab02988643ee0c1c77389dc0ce9ae28a5da4df42f9eb2749e0b0da4
DIST lxc-1.0.4.tar.gz 548741 SHA256 bcb04752fddc581030727be179a9f65715e11b0a04bf9bb119adb1b2d117bd9a SHA512 ec30e01e2dab393a74b50279981a9bb0e93da2ed2c82b33e218cd1146df20b5443a75ace623c30b6c9718f8a23e4a447484bf316c9155324fe931741d2ed9f06 WHIRLPOOL 2ae27940884bb645674410ff223f80e63b90cda7a4fdf189133ebab91621c0fc95ddb24e439f08ffbf93a3056e32dcc88cdc04ac75d9c4ad8a4779c177845074
DIST lxc-1.0.6.tar.gz 561249 SHA256 2aea199a89e2cd946f93406af6c3f62844f36954b79a6991b36d2c33022cb11c SHA512 fe85ccb57865d86704df6b4b79d60f31892785b07dc9dd2580cc6c384c89c29c23516e906b7a16bc03c6582c1fb2432bb8ff11bd17c09efa8f6a035fb41f46b1 WHIRLPOOL 9e77453fbe31523a2e8f39cfaba6f09fef68d00b54549167a0cde56c00934f827f5b4190b9fb64242f36782a9fcda63e6796c35fd47420870c2cee7b9bc0a1c8
EBUILD lxc-1.0.3.ebuild 5663 SHA256 fc8f781c81355a752453cd7db5491619395aa897070ef07a7b67bd8790574080 SHA512 090b12f3465535653b140237a5191af26158e63b855dfcc5f3f789c683b52ccec9188bab378cf3b47f8901370d920a581b828665efa1fc2a4451d932798c4901 WHIRLPOOL bf9ec6858a14934796ab32d3279198ceedd2d57faa6311f4ea2e19412a4c2d91c9e2e7e482f63c626262d93ab79d9d1e3c14ec9f14b75f1e3d8bd8cbfd590b19
EBUILD lxc-1.0.4.ebuild 5662 SHA256 83ba9709b7e7ef752f985054eba5d02f0b41455f58a7bc76e7911226a7ff265c SHA512 e8554f0a259d61b3a30de07136f2e993f64f7c4561c3cbdf37c7f071ebf6f700301e16491df7fc10a74f7362909ad56b1359af38d67f3703cf832d9a8d6dca85 WHIRLPOOL f66a876ed5677c30fae13baabdf3f02a18fcd553cfcf62ad2c704da0a3eb806329462e96a5a10bc0c88aca593aa6d123ef55266142cc03d7184e175210064962
-EBUILD lxc-1.0.6-r1.ebuild 6015 SHA256 3debd58512964908bbef0863fa24e8116ad672119212ee4f6530be0be69ea24d SHA512 10d22cf35b52925ec8bc7164c1f0dc2fffc26184e2cf112288e32e5080699b5d1558158cbcca61b84e8a9057dabaae88c964b18a07ca93966725f90766dc5497 WHIRLPOOL d26d80733a2b63d653b43d6aeb76294efb671ce153c6362aa9ba3d119b76e5eb7c2f735d29800ad85b51dcac146f101f4665019eb6bc54d4b2489157bad79b43
+EBUILD lxc-1.0.6-r1.ebuild 5953 SHA256 5027b1233f02a8be0d8d770208c8d24b189d7034cc839c3bf7dc5c02b2336e14 SHA512 d11af8d229546141beac2c9d2534b91d3bc7fc8e34313fba115982e00337e5ba3a89e8692e46e3c06612dbb3a4da9e024eef1d7fc56b1add68b72fca77c8394c WHIRLPOOL 8124df6bd14eb2035e1dcead31b22654bb3c91fecaf7b2dbadfb6b4bbd3124848a8617bb49d75523d65351eed6b92b455f30a9da6d906009da2303156a0b1fc4
EBUILD lxc-1.0.6.ebuild 5561 SHA256 65aa27cdb736a89935c8a0ebbd0e7719e891b1c76e6b227de498c417aea9a47f SHA512 9621cbc3c0acf923561ee2327a97c6a680f0e1b510cd5dc87721d951c4e3c7b264db09037c0f5216bf6036a30cba9e42c8f3ec831cd7d913be3dbbf615f62b4b WHIRLPOOL 02ea59945f0950087b64b806135f3a2414b36b384efa90a3502400334117a0d5e040db2d036086489165ce313c681bc6e273280c44cce4a44499c4fd1d59f9fd
diff --git a/app-emulation/lxc/files/lxc.initd.3 b/app-emulation/lxc/files/lxc.initd.3
index 37d4339f..9eb095c2 100644
--- a/app-emulation/lxc/files/lxc.initd.3
+++ b/app-emulation/lxc/files/lxc.initd.3
@@ -6,7 +6,7 @@
CONTAINER=${SVCNAME#*.}
lxc_get_configfile() {
- LXC_PATH="$( readlink -e "/var/lib" )"
+ LXC_PATH="$( readlink -e "$( lxc-config lxc.lxcpath 2>/dev/null || echo '/var/lib' )" )"
if [ -d "/etc/lxc" ] && [ -f "/etc/lxc/${CONTAINER}.conf" -o -f "/etc/lxc/${CONTAINER}/config" ]; then
ewarn "Legacy LXC configuration directory '/etc/lxc' found - please migrate your"
ewarn "configuration files to '${LXC_PATH}'"
diff --git a/app-emulation/lxc/lxc-1.0.6-r1.ebuild b/app-emulation/lxc/lxc-1.0.6-r1.ebuild
index d82d2746..073a67eb 100644
--- a/app-emulation/lxc/lxc-1.0.6-r1.ebuild
+++ b/app-emulation/lxc/lxc-1.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-1.0.6-r1.ebuild,v 1.5 2015/04/08 07:30:33 mgorny Exp $
+# $Id: a9b43e5f41beb7f40f0f9f68c1a03122537f7a69 $
EAPI="5"