summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2022-08-01 08:57:58 +0200
committerSven Eden <sven.eden@prydeworx.com>2022-08-01 08:57:58 +0200
commit4a9a50d65312ebb5978cbbf0364f1fea2c732c08 (patch)
treebab3648d81749fd06699900a7b4d59fa985235e5 /net-p2p
parentsci-misc/boinc: micro bump (diff)
downloadseden-4a9a50d65312ebb5978cbbf0364f1fea2c732c08.tar.gz
seden-4a9a50d65312ebb5978cbbf0364f1fea2c732c08.tar.bz2
seden-4a9a50d65312ebb5978cbbf0364f1fea2c732c08.zip
net-p2p/go-ethereum: new package, add 1.10.21
Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest3
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.10.21.ebuild43
-rw-r--r--net-p2p/go-ethereum/metadata.xml11
3 files changed, 57 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
new file mode 100644
index 0000000..5232155
--- /dev/null
+++ b/net-p2p/go-ethereum/Manifest
@@ -0,0 +1,3 @@
+DIST go-ethereum-1.10.21.tar.gz 13092971 BLAKE2B 3f36959229a34600f8f7da1554dd1cd966f9976b28601cfd6a4b9839b8ab71715e242defbcf9a1320515dd6d8a3599fce151711bb82c2fc8ad7eb8c6c466e20a SHA512 e0de96f35b8f70916cafed4652c453a47e90e256e4e53f5ba48f063fb40ccdcf03434d355c1d276996429c17601cdf8089c6c462536e91e351b497554571efb5
+EBUILD go-ethereum-1.10.21.ebuild 1047 BLAKE2B 783a55118573d3938585ff3def878a90504df3536d12e62cd4d799282d6fe382144c5718f655a76a3146cdd0e07b95b45521882b7617e07da4d645043a673e25 SHA512 caf385fa4297b6b1b0392edcd79253102bdbe83edc168ee5d0c4df84287fe2c0c5b8929bf4c7fe4e4df6551a8eccdb246532775c6b7248aa069c3387cd5d094c
+MISC metadata.xml 360 BLAKE2B 1f1e0d9403107259c286c1c2dd14bc39f1fa94574b8dad2adc7dbe7292906a6787ea714378de28cb03e36c200ca8566be086ee41ad87fa8cae58f06c1d10db29 SHA512 ea8959c2db79151f9b41d89659ee3eaded4b3d1dca8ed03be64f0af09472985d3a3deae88af00ffb144908c3d835deff0ec287de7746a76cb7fb675cd0b551b0
diff --git a/net-p2p/go-ethereum/go-ethereum-1.10.21.ebuild b/net-p2p/go-ethereum/go-ethereum-1.10.21.ebuild
new file mode 100644
index 0000000..0e998ce
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.10.21.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools"
+
+# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
+RESTRICT+=" test"
+
+src_compile() {
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+
+ if use devtools; then
+ dobin build/bin/abidump
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/checkpoint-admin
+ dobin build/bin/clef
+ dobin build/bin/devp2p
+ dobin build/bin/ethkey
+ dobin build/bin/evm
+ dobin build/bin/faucet
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ fi
+}
diff --git a/net-p2p/go-ethereum/metadata.xml b/net-p2p/go-ethereum/metadata.xml
new file mode 100644
index 0000000..d85725f
--- /dev/null
+++ b/net-p2p/go-ethereum/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <use>
+ <flag name="devtools">Build Ethereum development tools (evm, abigen, puppeth, ...)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ethereum/go-ethereum</remote-id>
+ </upstream>
+</pkgmetadata>