summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@prydeworx.com>2021-09-23 08:08:46 +0200
committerSven Eden <sven.eden@prydeworx.com>2021-09-23 08:08:46 +0200
commitb93c7045c6b2b91d4bf6527b3a2863c27590cf25 (patch)
treef839613222689ee77fc8e0a0013f10bb0d6eaf67 /media-video
parentmedia-libs/mlt and media-video/shotcut removed, they are both inm the tree no... (diff)
downloadseden-b93c7045c6b2b91d4bf6527b3a2863c27590cf25.tar.gz
seden-b93c7045c6b2b91d4bf6527b3a2863c27590cf25.tar.bz2
seden-b93c7045c6b2b91d4bf6527b3a2863c27590cf25.zip
media-video/shotcut: Bump to 21.09.20
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/metadata.xml15
-rw-r--r--media-video/shotcut/shotcut-21.09.20.ebuild66
3 files changed, 82 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
new file mode 100644
index 0000000..fee32bb
--- /dev/null
+++ b/media-video/shotcut/Manifest
@@ -0,0 +1 @@
+DIST shotcut-21.09.20.tar.gz 4358591 SHA256 f95f1aa5a7360b68ce9f2b1cffdb7344ff3db086bad77068233eb83114f25790 SHA512 6c2463c8d81c4e61b59d97ba2ee8f9aba5c420ee50b6c46c0e5f1c177e44cea6bc1fab5a7184ce8b13d2818b207efffe3c12f4d1682ce002279ba16c1c9bd624 WHIRLPOOL 35d46cb9321b702ea70b537ebe3345d4d693430dbcc20d323f553fe4f87ed8b60d51c67573c22ab7eef2256282cecde6a4bde7115e5289ad6a98ef34edba2e90
diff --git a/media-video/shotcut/metadata.xml b/media-video/shotcut/metadata.xml
new file mode 100644
index 0000000..c199e92
--- /dev/null
+++ b/media-video/shotcut/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>xdch47@posteo.de</email>
+ <name>Felix Neumärker</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mltframework/shotcut</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/shotcut/shotcut-21.09.20.ebuild b/media-video/shotcut/shotcut-21.09.20.ebuild
new file mode 100644
index 0000000..94b278e
--- /dev/null
+++ b/media-video/shotcut/shotcut-21.09.20.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
+fi
+
+IUSE="debug"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+COMMON_DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[widgets]
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-7.0.1[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
+ media-video/ffmpeg
+"
+DEPEND="${COMMON_DEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtquickcontrols:5
+ virtual/jack
+"
+
+src_configure() {
+ local myqmakeargs=(
+ PREFIX="${EPREFIX}/usr"
+ SHOTCUT_VERSION="${PV}"
+ DEFINES+=SHOTCUT_NOUPGRADE
+ )
+ use debug || myqmakeargs+=(DEFINES+=NDEBUG)
+
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}