summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Labedan <plabedan@gmail.com>2016-02-03 08:42:18 +0100
committerPaul Labedan <plabedan@gmail.com>2016-02-03 09:15:56 +0100
commitff407f27c8d6f438766af73584b07185a2675da1 (patch)
treed6c3cb0b72d879c7c1775f107b904a5dd5b6ffe6
parentremove enlightenment 0.19.* (diff)
downloadplab-ff407f27c8d6f438766af73584b07185a2675da1.tar.gz
plab-ff407f27c8d6f438766af73584b07185a2675da1.tar.bz2
plab-ff407f27c8d6f438766af73584b07185a2675da1.zip
add goaccess 0.9.7
-rw-r--r--net-analyzer/goaccess/Manifest3
-rw-r--r--net-analyzer/goaccess/files/fix_libtinfo_linking.patch32
-rw-r--r--net-analyzer/goaccess/goaccess-0.9.7.ebuild59
3 files changed, 94 insertions, 0 deletions
diff --git a/net-analyzer/goaccess/Manifest b/net-analyzer/goaccess/Manifest
new file mode 100644
index 0000000..cb10064
--- /dev/null
+++ b/net-analyzer/goaccess/Manifest
@@ -0,0 +1,3 @@
+AUX fix_libtinfo_linking.patch 1175 SHA256 c67e619f3599f17b1a957f75a2aeb40fe4a32e251f294e667f6ef29b2bef6337 SHA512 ca0948de5af35140b1f9492a9dc58f30567b9b8dfcbedcf3fa7b11493150b8269dea9aa6ebb5a6b6e7c285eb5a592357deb2ddd72517580a519ad665daa0ed7c WHIRLPOOL 063a11ebe029ab1d4c92a6c8c46013769f600d004fe63bd9ef48c970db024df144a1f3428df97fd6c406d757bdd012360b4b56ae9d36c185c2103a1b0fc68fae
+DIST goaccess-0.9.7.tar.gz 270009 SHA256 9427e6425cb71638d08fcdc45d63190c45ea5a10e28a03def24a9b8bdd584e34 SHA512 27c54401fb5ce086f191c8a1ba0a86b6c155469a3f412be64924f3fa3a80f3e04541c805fb98539b47872d06cf4e2c89150c20351d08c68139c63b17de17adb8 WHIRLPOOL 868305d56b5c569504df607e87efea2238930ba7b89337bbceb7b6d5c79c1b2d1298daa9b651c052bc3dfd45d0493b164978d701505fd581ae8d6742bf0d0e4a
+EBUILD goaccess-0.9.7.ebuild 1280 SHA256 ec83ebf5968a80f90ce5f00795776b856a9ec106ae7e700d2cbc0d83dbe7a971 SHA512 48e958d2ae95e2c0c3cc244ac20a3911c3c7b96b0c6e3a952dd030fe11df19a018368f6e1efd53c09aa2a7e1a37857c62efcd0da616c657cd4b2d27e160a3ac7 WHIRLPOOL 1de83eaf6543aacbbaaf4e0cf356c5e97e8c0302833286c101148e28931af2f98b66ab1dc0dd9cef1739e08a5b70168672c6c971769106fe11f0673eeafaf70a
diff --git a/net-analyzer/goaccess/files/fix_libtinfo_linking.patch b/net-analyzer/goaccess/files/fix_libtinfo_linking.patch
new file mode 100644
index 0000000..8b1db60
--- /dev/null
+++ b/net-analyzer/goaccess/files/fix_libtinfo_linking.patch
@@ -0,0 +1,32 @@
+From 6dc27f8815ebbcdc1ab3dd191e9f04b71535c5b5 Mon Sep 17 00:00:00 2001
+From: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua>
+Date: Fri, 1 Jan 2016 17:40:45 +0200
+Subject: [PATCH] Correctly link against libtinfo
+
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 894e2b4..6a722dd 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -67,6 +67,7 @@ AC_ARG_ENABLE(utf8, [ --enable-utf8 Enable ncurses library that handles wide
+ if test "$utf8" = "yes"; then
+ AC_CHECK_LIB([ncursesw], [mvaddwstr], [],
+ [AC_MSG_ERROR([*** Missing development libraries for ncursesw])])
++ AC_SEARCH_LIBS([stdscr], [tinfow], ,[AC_MSG_ERROR([Cannot find a library providing stdscr])])
+
+ have_ncurses="yes"
+ AC_CHECK_HEADERS([ncursesw/ncurses.h],[have_ncurses=yes], [], [
+@@ -87,6 +88,7 @@ if test "$utf8" = "yes"; then
+ else
+ AC_CHECK_LIB([ncurses], [refresh], [],
+ [AC_MSG_ERROR([*** Missing development libraries for ncurses])])
++ AC_SEARCH_LIBS([stdscr], [tinfo], ,[AC_MSG_ERROR([Cannot find a library providing stdscr])])
+
+ have_ncurses="yes"
+ AC_CHECK_HEADERS([ncurses/ncurses.h],[have_ncurses=yes], [], [
+--
+2.7.0
+
diff --git a/net-analyzer/goaccess/goaccess-0.9.7.ebuild b/net-analyzer/goaccess/goaccess-0.9.7.ebuild
new file mode 100644
index 0000000..121b7fb
--- /dev/null
+++ b/net-analyzer/goaccess/goaccess-0.9.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
+HOMEPAGE="http://goaccess.io"
+SRC_URI="http://tar.goaccess.io/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="btree debug geoip getline tokyocabinet unicode"
+
+REQUIRED_USE="btree? ( tokyocabinet )"
+
+RDEPEND="
+ sys-libs/ncurses[unicode?]
+ geoip? ( dev-libs/geoip )
+ !tokyocabinet? ( dev-libs/glib:2 )
+ tokyocabinet? (
+ dev-db/tokyocabinet
+ btree? (
+ app-arch/bzip2
+ sys-libs/zlib
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+
+ epatch "${FILESDIR}/fix_libtinfo_linking.patch" # this patch is already on master branch
+
+ # Fix path to GeoIP bases in config
+ sed -e s':/usr/local:/usr:' -i config/goaccess.conf || die
+}
+
+src_configure() {
+ eautoreconf -fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable geoip) \
+ $(use_enable unicode utf8) \
+ $(use_enable tokyocabinet tcb) \
+ $(use_enable btree bzip) \
+ $(use_enable btree zlib) \
+ $(use_enable btree zlib) \
+ $(usex tokyocabinet "--enable-tcb=$(usex btree btree memhash)" '') \
+ $(use_with getline)
+}