summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2020-04-09 14:29:30 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2020-04-09 14:29:30 +0800
commit1aaac9c4ef93d44f8763dcf151a25be8c11bc89f (patch)
treea50b56ca60647045ec4d5ea224679a61df5699b3
parentAdd net-im/telegram-cli v20200106 (diff)
downloadpigfoot-1aaac9c4ef93d44f8763dcf151a25be8c11bc89f.tar.gz
pigfoot-1aaac9c4ef93d44f8763dcf151a25be8c11bc89f.tar.bz2
pigfoot-1aaac9c4ef93d44f8763dcf151a25be8c11bc89f.zip
Add app-crypt/tlsh v4.2.1
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--app-crypt/tlsh/Manifest1
l---------app-crypt/tlsh/tlsh-4.2.1.ebuild1
-rw-r--r--app-crypt/tlsh/tlsh-9999.ebuild48
3 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/tlsh/Manifest b/app-crypt/tlsh/Manifest
new file mode 100644
index 0000000..1ff7fd6
--- /dev/null
+++ b/app-crypt/tlsh/Manifest
@@ -0,0 +1 @@
+DIST tlsh-4.2.1.tar.gz 3326729 BLAKE2B 666d2854efc880f37ee838c0798e50485c4e6411bd889692674852cb9b54fc232354aa65f55a905544e966b2c1ed37caddd369c49297fe0812dc951e61fe6c48 SHA512 ee653f02e96c839cb62262b1dcb84e3946801ef70a5b13f6596236d85931c4aa069de276021d8e4f1a8e95ce3c97946b73e7d0792fc82434ac539bb70dc9922e
diff --git a/app-crypt/tlsh/tlsh-4.2.1.ebuild b/app-crypt/tlsh/tlsh-4.2.1.ebuild
new file mode 120000
index 0000000..524efd2
--- /dev/null
+++ b/app-crypt/tlsh/tlsh-4.2.1.ebuild
@@ -0,0 +1 @@
+tlsh-9999.ebuild \ No newline at end of file
diff --git a/app-crypt/tlsh/tlsh-9999.ebuild b/app-crypt/tlsh/tlsh-9999.ebuild
new file mode 100644
index 0000000..b682cab
--- /dev/null
+++ b/app-crypt/tlsh/tlsh-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="github.com/trendmicro/${PN}"
+MY_P="${P}"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${MY_PN}"
+ EGIT_SUBMODULES=()
+else
+ EGIT_COMMIT=${PV}
+ MY_P="${PN}-${EGIT_COMMIT}"
+ SRC_URI="https://${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Trend Micro Locality Sensitive Hash"
+HOMEPAGE="https://github.com/trendmicro/tlsh"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PVR}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_BUILD_TYPE=Release
+
+src_compile() {
+ sh ./make.sh -notest
+}
+
+src_install() {
+ cmake_src_install
+
+ # Manually install supporting files that conflict with other packages
+ # but are needed for galera and initial installation
+ exeinto /usr/bin
+ newexe "${S}/bin/tlsh_unittest" tlsh
+}