summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtur Maciąg <maciag.artur@gmail.com>2010-04-23 01:46:56 +0200
committerArtur Maciąg <maciag.artur@gmail.com>2010-04-23 01:46:56 +0200
commiteff39b8edcd86d519900d593dbae7b4c3fe8974b (patch)
tree8d1a08aeb605d433d87c175ffe1dcdb9355cc185 /games-emulation
parenttlenlinux version bump (diff)
downloadpiczu-eff39b8edcd86d519900d593dbae7b4c3fe8974b.tar.gz
piczu-eff39b8edcd86d519900d593dbae7b4c3fe8974b.tar.bz2
piczu-eff39b8edcd86d519900d593dbae7b4c3fe8974b.zip
dolphin live and dolphin-bin ebuilds added
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dolphin-bin/Manifest5
-rw-r--r--games-emulation/dolphin-bin/dolphin-bin-1.0-r3903.ebuild37
-rw-r--r--games-emulation/dolphin-bin/dolphin-bin-2.0.ebuild49
-rw-r--r--games-emulation/dolphin/Manifest1
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild56
5 files changed, 148 insertions, 0 deletions
diff --git a/games-emulation/dolphin-bin/Manifest b/games-emulation/dolphin-bin/Manifest
new file mode 100644
index 0000000..3f39396
--- /dev/null
+++ b/games-emulation/dolphin-bin/Manifest
@@ -0,0 +1,5 @@
+DIST dolphin-2.0.amd64.tar.bz2 2894248 RMD160 5f423426f3f1d68fa626f1a903d0da5c99656746 SHA1 6081b0bce5c0fe59270737de95626acddd3a50d1 SHA256 fe6290a5eb10c93da57a4daa26d42bb473afdc4815b3ce14c15ebdd6eb6a9114
+DIST dolphin-2.0.i686.tar.bz2 2620518 RMD160 f301779a6dbb1b343de587f46ec3a23432782b67 SHA1 27c33b67c03004df2bd5677af9038f0ea1a4fc1b SHA256 82a23cd093a2236416765f3b79defe5b7fb57f68f96025ce2a814dacbe5487e0
+DIST dolphin-3903-release.tar.bz2 2171784 RMD160 156de9c8284cd0dfb21752d3cd5b9dcbc902bea5 SHA1 49ef1b72be4ff6fc19978e08f6ac319715e0e683 SHA256 a840d00797f2064db11f580bc8ec906f285f98ef7ef1b628d47cc984df6146e1
+EBUILD dolphin-bin-1.0-r3903.ebuild 902 RMD160 c9b65609d7f9bb56dd07a9dc04c460e7d2fb3a2c SHA1 dff7d456a5d440a8cccd51ae5394906bdeebe81d SHA256 8edc3a8adaad78164778099557e3411204cf26eb4d1ed7eac04f32b872583a10
+EBUILD dolphin-bin-2.0.ebuild 1158 RMD160 a5db11bc8a2d49c06d77d350fc0bbee8f80a8c38 SHA1 d7aba10cb473ec2cbce0abcf9cad3835612d82df SHA256 b5fcd58755a5d383f57f33dda1a3f30dfd3192ce6d9edaa05cf9e61dd177c77e
diff --git a/games-emulation/dolphin-bin/dolphin-bin-1.0-r3903.ebuild b/games-emulation/dolphin-bin/dolphin-bin-1.0-r3903.ebuild
new file mode 100644
index 0000000..8e1b6af
--- /dev/null
+++ b/games-emulation/dolphin-bin/dolphin-bin-1.0-r3903.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI=2
+
+inherit eutils
+
+MY_PN="${PN/-bin}"
+MY_PV="${PR/r}"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="Gamecube and Wii emulator"
+HOMEPAGE="http://dolphin-emu.com"
+SRC_URI="http://www.cs.huji.ac.il/~elylevy/${MY_PN}/i686/${MY_P}-release.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+wiimote +portaudio"
+
+DEPEND="${RDEPEND}"
+RDEPEND="=media-libs/openal-1*
+ x11-libs/wxGTK:2.8
+ media-gfx/nvidia-cg-toolkit
+ portaudio? ( media-libs/portaudio )
+ wiimote? ( games-util/wiiuse )"
+S="${WORKDIR}/Binary/Linux-i686"
+
+src_install() {
+ local INSTDIR="/opt/${MY_PN}"
+ dodir ${INSTDIR}
+ # Remove SVN dirs
+ rm -rf `find ${S} -type d -name .svn`
+ cp -pR ${S}/* ${D}${INSTDIR} || die
+ # Which group?
+ #fowners root:users ${INSTDIR}/Dolphin
+ dosym ${INSTDIR}/Dolphin /usr/bin/Dolphin
+}
diff --git a/games-emulation/dolphin-bin/dolphin-bin-2.0.ebuild b/games-emulation/dolphin-bin/dolphin-bin-2.0.ebuild
new file mode 100644
index 0000000..8ff02f4
--- /dev/null
+++ b/games-emulation/dolphin-bin/dolphin-bin-2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils games
+
+MY_PN="${PN/-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Gamecube and Wii emulator"
+HOMEPAGE="http://dolphin-emu.com"
+SRC_URI="x86? ( http://dolphin.jcf129.com/dolphin-2.0.i686.tar.bz2 )
+ amd64? ( http://dolphin.jcf129.com/dolphin-2.0.amd64.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="wiimote"
+
+RDEPEND="=media-libs/openal-1*
+ x11-libs/wxGTK:2.8
+ media-gfx/nvidia-cg-toolkit
+ media-libs/portaudio
+ wiimote? ( games-util/wiiuse )"
+DEPEND="${RDEPEND}"
+
+if use x86; then
+ S="${WORKDIR}/Binary/Linux-i686"
+elif use amd64; then
+ S="${WORKDIR}/Binary/Linux-x86_64"
+fi
+
+src_prepare() {
+ # Remove SVN dirs
+ rm -rf `find ${S} -type d -name .svn`
+}
+
+src_install() {
+ local INSTDIR="${GAMES_PREFIX_OPT}/${MY_PN}"
+ insinto ${INSTDIR}
+ exeinto ${INSTDIR}
+ doins -r lib plugins sys user
+ doexe dsptool dolphin-emu
+ games_make_wrapper dolphin-emu "./dolphin-emu" ${INSTDIR} "${INSTDIR}/lib ${INSTDIR}/sys ${INSTDIR}/plugins"
+ make_desktop_entry dolphin-emu "Dolphin Emulator"
+ prepgamesdirs
+}
diff --git a/games-emulation/dolphin/Manifest b/games-emulation/dolphin/Manifest
new file mode 100644
index 0000000..e377e1d
--- /dev/null
+++ b/games-emulation/dolphin/Manifest
@@ -0,0 +1 @@
+EBUILD dolphin-9999.ebuild 1248 RMD160 148d33b604d56301e4a4b20cca24bca1815671be SHA1 57cb2b95f588e7e272c7d96ce9cba2960cc2e5d2 SHA256 50759dd4a1fc6b8cb90bf3071d75796a16cf39d3020eacebddbede31a961d85e
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
new file mode 100644
index 0000000..7ae9d77
--- /dev/null
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+ESVN_REPO_URI="http://dolphin-emu.googlecode.com/svn/trunk/"
+
+inherit eutils games subversion
+
+DESCRIPTION="Gamecube and Wii emulator"
+HOMEPAGE="http://dolphin-emu.com"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lzo openal sfml"
+
+RDEPEND="x11-libs/wxGTK:2.8
+ media-gfx/nvidia-cg-toolkit
+ media-libs/portaudio
+ games-util/wiiuse
+ virtual/opengl
+ virtual/glu
+ lzo? ( dev-libs/lzo )
+ openal? ( =media-libs/openal-1* )
+ sfml? ( media-libs/libsfml )"
+DEPEND="${RDEPEND}
+ dev-util/scons
+ dev-util/pkgconfig"
+
+S=${WORKDIR}
+
+SCONSOPTS=""
+
+src_configure() {
+ SCONSOPTS=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
+ use lzo && SCONSOPTS="${SCONSOPTS} shared_lzo=yes"
+ use openal && SCONSOPTS="${SCONSOPTS} openal=yes"
+ use sfml && SCONSOPTS="${SCONSOPTS} shared_sfml=yes"
+}
+
+src_compile() {
+ scons \
+ install=global \
+ prefix=${GAMES_PREFIX} \
+ destdir=${D} \
+ ${SCONSOPTS} || die "scons failed"
+}
+
+src_install() {
+ scons ${SCONSOPTS} install || die "scons install failed"
+ make_desktop_entry dolphin-emu "Dolphin Emulator"
+ prepgamesdirs
+}