summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <mvath@google.com>2019-08-04 16:28:46 +0200
committerMartin Väth <mvath@google.com>2019-08-04 16:28:46 +0200
commitcdab6ab70c8df4b7f74f2da64215874a9d9934d5 (patch)
tree549dcf848aecceedd917e0d52b35120cacd5f17e /app-shells
parentsys-fs/squashfs-tools: Version bump (diff)
downloadmv-cdab6ab70c8df4b7f74f2da64215874a9d9934d5.tar.gz
mv-cdab6ab70c8df4b7f74f2da64215874a9d9934d5.tar.bz2
mv-cdab6ab70c8df4b7f74f2da64215874a9d9934d5.zip
Support USE=-split-usr
Signed-off-by: Martin Väth <mvath@google.com>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/push/push-3.1-r4.ebuild (renamed from app-shells/push/push-3.1-r3.ebuild)12
-rw-r--r--app-shells/schily-tools/Manifest2
-rw-r--r--app-shells/schily-tools/schily-tools-2019.07.22.ebuild (renamed from app-shells/schily-tools/schily-tools-2019.06.13.ebuild)13
3 files changed, 21 insertions, 6 deletions
diff --git a/app-shells/push/push-3.1-r3.ebuild b/app-shells/push/push-3.1-r4.ebuild
index 5be4e7b4..865ec04c 100644
--- a/app-shells/push/push-3.1-r3.ebuild
+++ b/app-shells/push/push-3.1-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2012-2018 Martin V\"ath
+# Copyright 2012-2019 Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,15 +11,19 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
+IUSE="split-usr"
# Install into / to let sys-block/zram-init work with split /usr
src_compile() {
- emake PREFIX= EPREFIX="${EPREFIX}" DATADIR=/lib/push
+ emake PREFIX= EPREFIX="${EPREFIX}" BINDIR=$(get_usr)/bin DATADIR=$(get_usr)/lib/push
}
src_install() {
dodoc README.md
- emake DESTDIR="${ED}" PREFIX= EPREFIX="${EPREFIX}" DATADIR=/lib/push install
+ emake DESTDIR="${ED}" PREFIX= EPREFIX="${EPREFIX}" BINDIR=$(get_usr)/bin DATADIR=$(get_usr)/lib/push install
+}
+
+get_usr() {
+ use split-usr || echo /usr
}
diff --git a/app-shells/schily-tools/Manifest b/app-shells/schily-tools/Manifest
index d696be2b..807b47af 100644
--- a/app-shells/schily-tools/Manifest
+++ b/app-shells/schily-tools/Manifest
@@ -1 +1 @@
-DIST schily-2019-06-13.tar.bz2 4326815 SHA512 db448c24d455e6c2e302f5ca2fa46bbb9d74cc094e2cf97ebce7d06de3673c6e7a11fd3ea98d414a694e859bbd988f62f9090a5e8a4b01982ef50698b322d4e3
+DIST schily-2019-07-22.tar.bz2 4343597 SHA512 632a61abc47d13ab6331db382cd79b0cc6dafee9d8238dc4d1e3815f0cbad57823c0f9e4418f3246621521acd8cd2a3d2cf5937fe72e074d94d94559b22fcacf
diff --git a/app-shells/schily-tools/schily-tools-2019.06.13.ebuild b/app-shells/schily-tools/schily-tools-2019.07.22.ebuild
index abbd2695..18c751fe 100644
--- a/app-shells/schily-tools/schily-tools-2019.06.13.ebuild
+++ b/app-shells/schily-tools/schily-tools-2019.07.22.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/schilytools/${MY_P}.tar.bz2"
DESCRIPTION="Many tools from Joerg Schilling, including a POSIX compliant Bourne Shell"
HOMEPAGE="https://sourceforge.net/projects/schilytools/"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="acl caps doc nls suid unicode xattr"
+IUSE="acl caps doc nls split-usr suid unicode xattr"
REQUIRED_USE_WARN="amd64-fbsd? ( !xattr )"
PATCHES=("${FILESDIR}"/strlcat-mapvers.patch)
@@ -216,6 +216,9 @@ src_prepare() {
libcdrdeflt libedc libfile libhfs_iso libparanoia \
librscg libscgcmd libsiconv 'libsiconv!@!tables'
fi
+ if ! use acl; then
+ sed -i -e 's/^CPPOPTS.*DUSE_ACL/#&/' -- star/Makefile || die
+ fi
# nonexistent:
# ! use schilytools_cmd || targets cmd
! use schilytools_compare || targets compare
@@ -483,6 +486,14 @@ src_install() {
if use renameschily_getopt && have_target libgetopt; then
mv -v -- "${ED}"/usr/share/man/man3/{,schily-}getopt.3 || die
fi
+ use split-usr || move_to_usr_bin "${ED}"/bin/*
+}
+
+move_to_usr_bin() {
+ test -r "$1" || return 0
+ test -d "${ED}"/usr/bin || mkdir -p -- "${ED}"/usr/bin || die
+ mv -v -- "$@" "${ED}"/usr/bin || die
+ rmdir "${ED}"/bin || die
}
pkg_postinst() {