summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2014-04-14 23:19:34 -0400
committerJustin Riley <justin.t.riley@gmail.com>2014-04-14 23:19:34 -0400
commit86023588386da6b7fbec0da4a2df7524ac69d5c0 (patch)
tree74f8bd1aff936572172d30462c30d87f06fe26d2 /dev-python
parentadd ebuild for et-sdl-sound-29 (diff)
downloadjtriley-86023588386da6b7fbec0da4a2df7524ac69d5c0.tar.gz
jtriley-86023588386da6b7fbec0da4a2df7524ac69d5c0.tar.bz2
jtriley-86023588386da6b7fbec0da4a2df7524ac69d5c0.zip
cruft clean up
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyzmq/pyzmq-9999.ebuild44
-rw-r--r--dev-python/rtmapi/Manifest1
-rw-r--r--dev-python/rtmapi/rtmapi-0.5.ebuild21
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/pyzmq/pyzmq-9999.ebuild b/dev-python/pyzmq/pyzmq-9999.ebuild
deleted file mode 100644
index 2170f94..0000000
--- a/dev-python/pyzmq/pyzmq-9999.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils flag-o-matic git-2
-
-DESCRIPTION="Python bindings for zeromq."
-HOMEPAGE="http://www.zeromq.org/bindings:python"
-EGIT_REPO_URI="git://github.com/zeromq/${PN}.git"
-
-IUSE="doc examples"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-LICENSE="LGPL-3"
-
-DEPEND="dev-python/setuptools
- =net-libs/zeromq-9999"
-
-src_prepare() {
- sed -e "s#library_dirs = .*#library_dirs = $(pkg-config --variable libdir libzmq)#" \
- -e "s#include_dirs = .*#include_dirs = $(pkg-config --variable includedir libzmq)#" \
- setup.cfg.template > setup.cfg || die
-}
-
-src_compile() {
- # Python 2 breaks strict aliasing. Don't use this flag with Python 3.
- append-flags -fno-strict-aliasing
-
- distutils_src_compile
-}
-
-src_install() {
- distutils_src_install
- insinto /usr/share/doc/${PF}
- if use examples; then
- doins -r examples || die
- fi
-}
diff --git a/dev-python/rtmapi/Manifest b/dev-python/rtmapi/Manifest
deleted file mode 100644
index ed303d3..0000000
--- a/dev-python/rtmapi/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rtmapi-0.5.tar.gz 26095 SHA256 81eecbc06aafa3088e9430f9f02e219ae03cc160ba0d261d8e17583fd22def81 SHA512 d1ab15a959b9dd254754d473e8e29d9f34c19eadd28b8256ad36f20f8b81d904a832479d5c75572f48cbf8166568d7d802d985611548a0656aa5e63c5846e72f WHIRLPOOL 170a125f8a439b961e74a0902d887395e0c14db5a30d452a94ef4a50377835c7843971b1b24a30948f2ddbbef6a9d7f92c2f08c2b58fb3e3e2744bc3fbb1918a
diff --git a/dev-python/rtmapi/rtmapi-0.5.ebuild b/dev-python/rtmapi/rtmapi-0.5.ebuild
deleted file mode 100644
index 2ccb2ed..0000000
--- a/dev-python/rtmapi/rtmapi-0.5.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-1.0a.ebuild,v 1.2 2008/01/18 03:05:35 mr_bones_ Exp $
-EAPI="4"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-IUSE=""
-DESCRIPTION="Remember the Milk API in Python"
-HOMEPAGE="http://code.google.com/p/rtmapi/"
-SRC_URI="http://rtmapi.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=dev-lang/python-2.4"