summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJens Pranaitis <jens@chaox.net>2010-05-15 12:37:43 +0200
committerJens Pranaitis <jens@chaox.net>2010-05-15 12:37:43 +0200
commit2a08e3e1d0ec91de401c671d223d6d00217865ee (patch)
tree98d4f8c66af9820f2e65e67da8c9025fc4bf435a
parentdeadbeef: added (diff)
downloadjensp-2a08e3e1d0ec91de401c671d223d6d00217865ee.tar.gz
jensp-2a08e3e1d0ec91de401c671d223d6d00217865ee.tar.bz2
jensp-2a08e3e1d0ec91de401c671d223d6d00217865ee.zip
Added lugaru
-rw-r--r--games-action/lugaru-data/Manifest1
-rw-r--r--games-action/lugaru-data/lugaru-data-9999.ebuild27
-rw-r--r--games-action/lugaru/Manifest1
-rw-r--r--games-action/lugaru/lugaru-9999.ebuild48
4 files changed, 77 insertions, 0 deletions
diff --git a/games-action/lugaru-data/Manifest b/games-action/lugaru-data/Manifest
new file mode 100644
index 0000000..dcce04d
--- /dev/null
+++ b/games-action/lugaru-data/Manifest
@@ -0,0 +1 @@
+EBUILD lugaru-data-9999.ebuild 501 RMD160 9f97c8300855ec1eb3e35c0b2c50246b9a3ab43b SHA1 0999d5fa61120b983f36c806fe03c20968e09862 SHA256 58e4a0f83c53a7495288dc3bdb2aa597df96855d4770feea3ab5ac8825925973
diff --git a/games-action/lugaru-data/lugaru-data-9999.ebuild b/games-action/lugaru-data/lugaru-data-9999.ebuild
new file mode 100644
index 0000000..03e9c16
--- /dev/null
+++ b/games-action/lugaru-data/lugaru-data-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit mercurial
+
+DESCRIPTION="a cross platform 3d action adventure - data files"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI=""
+EHG_REPO_URI="http://hg.icculus.org/icculus/lugaru"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="games-action/lugaru-data"
+
+S="${WORKDIR}"/lugaru
+
+src_install() {
+ insinto /opt/lugaru/
+ doins -r Data || die
+}
diff --git a/games-action/lugaru/Manifest b/games-action/lugaru/Manifest
new file mode 100644
index 0000000..2de3a19
--- /dev/null
+++ b/games-action/lugaru/Manifest
@@ -0,0 +1 @@
+EBUILD lugaru-9999.ebuild 970 RMD160 58f93401aeaaf5f877f6284affb7cad7040e0436 SHA1 211cd97a51a886b7f35158ab422192498220b177 SHA256 e522850f5f2dc8a7483d6398a13708cc6eac083abe7acdb376031122b91ff82b
diff --git a/games-action/lugaru/lugaru-9999.ebuild b/games-action/lugaru/lugaru-9999.ebuild
new file mode 100644
index 0000000..2d2e6ff
--- /dev/null
+++ b/games-action/lugaru/lugaru-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cmake-utils games mercurial
+
+DESCRIPTION="a cross platform 3d action adventure"
+HOMEPAGE="http://www.wolfire.com/lugaru"
+SRC_URI=""
+EHG_REPO_URI="http://hg.icculus.org/icculus/lugaru"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="media-libs/openal
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/libsdl
+ virtual/opengl
+ media-libs/libvorbis
+ media-libs/libogg"
+RDEPEND="${DEPEND}
+ games-action/lugaru-data"
+
+S="${WORKDIR}"/${PN}
+
+pkg_setup() {
+ mycmakeargs="-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX_OPT}/${PN}"
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ rm -rf "${D}"/opt/lugaru/Data
+ games_make_wrapper lugaru ./lugaru "${GAMES_PREFIX_OPT}/${PN}" "${GAMES_PREFIX_OPT}/${PN}"
+ make_desktop_entry lugaru "Neverwinter Nights"
+}