summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/swarm/swarm-2.2.3.ebuild')
-rw-r--r--sci-misc/swarm/swarm-2.2.3.ebuild46
1 files changed, 19 insertions, 27 deletions
diff --git a/sci-misc/swarm/swarm-2.2.3.ebuild b/sci-misc/swarm/swarm-2.2.3.ebuild
index e60c683..610cf63 100644
--- a/sci-misc/swarm/swarm-2.2.3.ebuild
+++ b/sci-misc/swarm/swarm-2.2.3.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+EAPI=4
+
+inherit eutils java-pkg-2
DESCRIPTION="Swarm is a platform for agent-based models."
HOMEPAGE="http://www.swarm.org"
@@ -13,34 +15,25 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="java hdf5"
-DEPEND="dev-lang/tcl
- dev-lang/tk
- dev-tcltk/blt
- >=media-libs/libpng-1.2.5
- >=sys-libs/zlib-1.2.2
- x11-libs/libXpm
- virtual/emacs
- hdf5? ( >=sci-libs/hdf5-1.6.2 )
- java? ( >=virtual/jdk-1.4.2 )"
+DEPEND="
+ sys-devel/gcc[objc]
+ dev-lang/tcl
+ dev-lang/tk
+ dev-tcltk/blt
+ >=media-libs/libpng-1.2.5
+ >=sys-libs/zlib-1.2.2
+ x11-libs/libXpm
+ virtual/emacs
+ hdf5? ( >=sci-libs/hdf5-1.6.2 )
+ java? ( >=virtual/jdk-1.4.2 )
+"
RDEPEND="${DEPEND}"
-pkg_setup() {
- if ! built_with_use --missing false gcc objc ; then
- eerror "Your GCC compiler has been built without Objective-C support."
- eerror "Please enable the 'objc' USE flag and re-emerge sys-devel/gcc."
- elog "You can enable this USE flag either globally in /etc/make.conf,"
- elog "or just for specific packages in /etc/portage/package.use."
- die "sys-devel/gcc missing objc support"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-amd64.patch
-}
+PATCHES=(
+ "${FILESDIR}/${P}-amd64.patch"
+)
-src_compile() {
+src_configure() {
javaconf="--without-jdkdir"
use java && javaconf="--with-jdkdir=`java-config -O`"
hdf5conf="--without-hdf5dir"
@@ -50,7 +43,6 @@ src_compile() {
${javaconf} \
${hdf5conf} \
|| die "econf failed"
- emake || die "emake failed"
}
src_install() {