summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@falcon.eroen.eu>2014-02-04 19:18:42 +0100
committereroen <eroen@falcon.eroen.eu>2014-03-01 22:10:17 +0100
commit042d6283c6602a2caef499a74629c3e82615bb8b (patch)
treeab4faff5c5219072c2f4a7fa60ee81d01d0d0e11 /dev-python
parentswitch to thin manifests (diff)
downloaderoen-042d6283c6602a2caef499a74629c3e82615bb8b.tar.gz
eroen-042d6283c6602a2caef499a74629c3e82615bb8b.tar.bz2
eroen-042d6283c6602a2caef499a74629c3e82615bb8b.zip
dev-python/m3u8 - new
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/m3u8/Manifest1
-rw-r--r--dev-python/m3u8/m3u8-0.1.6.ebuild45
-rw-r--r--dev-python/m3u8/m3u8-9999.ebuild45
-rw-r--r--dev-python/m3u8/metadata.xml6
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/m3u8/Manifest b/dev-python/m3u8/Manifest
new file mode 100644
index 0000000..bdd0675
--- /dev/null
+++ b/dev-python/m3u8/Manifest
@@ -0,0 +1 @@
+DIST m3u8-0.1.6.tar.gz 6559 SHA256 dc56bc64781d676ddcd5c2ec6053c37bd9c3997691a04e309b815d82a3176459 SHA512 bbb6299fb903a4021c0c3b67f1bf490692caa4d60109ed3de36fec1e41089cfb2077fe722eedc32dea2cb226f7a3478b8f443cae8b8ff3f4641f1e0bc3da97e2 WHIRLPOOL c55a1303b27149ee5007997a7cc1146b3e42ec24c8dd87ac1bdf6baf16c4c4e91826cdb5b006355a9bb1c36ee7c90223e6ceecb9661953de36b51b55e45002d8
diff --git a/dev-python/m3u8/m3u8-0.1.6.ebuild b/dev-python/m3u8/m3u8-0.1.6.ebuild
new file mode 100644
index 0000000..9e2335a
--- /dev/null
+++ b/dev-python/m3u8/m3u8-0.1.6.ebuild
@@ -0,0 +1,45 @@
+# By eroen, 2014
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# $Header: $
+
+EAPI=5
+# needs 2to3 for urlparse
+PYTHON_COMPAT=(python2_7)
+
+DESCRIPTION="m3u8 parser"
+HOMEPAGE="https://pypi.python.org/pypi/m3u8 https://github.com/globocom/m3u8"
+if [[ ${PV} == *9999* ]]; then
+ inherit distutils-r1 git-r3
+ EGIT_REPO_URI="https://github.com/globocom/m3u8.git"
+ VCS_DEPEND="dev-vcs/git[curl]"
+else
+ inherit distutils-r1
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# test suite missing from tarballs
+[[ ${PV} != *9999* ]] && RESTRICT="test"
+
+DEPEND="${VCS_DEPEND}
+ test? ( app-shells/bash
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sys-apps/coreutils
+ sys-apps/findutils
+ sys-apps/grep
+ sys-process/procps )"
+RDEPEND=""
+
+python_test() {
+ sed -e '/pip install/c:' \
+ -i runtests || die
+ ./runtests || die
+}
diff --git a/dev-python/m3u8/m3u8-9999.ebuild b/dev-python/m3u8/m3u8-9999.ebuild
new file mode 100644
index 0000000..9e2335a
--- /dev/null
+++ b/dev-python/m3u8/m3u8-9999.ebuild
@@ -0,0 +1,45 @@
+# By eroen, 2014
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# $Header: $
+
+EAPI=5
+# needs 2to3 for urlparse
+PYTHON_COMPAT=(python2_7)
+
+DESCRIPTION="m3u8 parser"
+HOMEPAGE="https://pypi.python.org/pypi/m3u8 https://github.com/globocom/m3u8"
+if [[ ${PV} == *9999* ]]; then
+ inherit distutils-r1 git-r3
+ EGIT_REPO_URI="https://github.com/globocom/m3u8.git"
+ VCS_DEPEND="dev-vcs/git[curl]"
+else
+ inherit distutils-r1
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# test suite missing from tarballs
+[[ ${PV} != *9999* ]] && RESTRICT="test"
+
+DEPEND="${VCS_DEPEND}
+ test? ( app-shells/bash
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sys-apps/coreutils
+ sys-apps/findutils
+ sys-apps/grep
+ sys-process/procps )"
+RDEPEND=""
+
+python_test() {
+ sed -e '/pip install/c:' \
+ -i runtests || die
+ ./runtests || die
+}
diff --git a/dev-python/m3u8/metadata.xml b/dev-python/m3u8/metadata.xml
new file mode 100644
index 0000000..2577434
--- /dev/null
+++ b/dev-python/m3u8/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>