summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2010-01-19 13:29:12 -0500
committerRussell Harmon <russ@eatnumber1.com>2010-01-19 13:29:12 -0500
commite5b3e12558e4a487b185e508933f94e61d92cc20 (patch)
tree5b0d6c1a5701a88328be90471aedeabc98e51178
parentAdd supergameboy-0.014 (diff)
downloadeatnumber1-e5b3e12558e4a487b185e508933f94e61d92cc20.tar.gz
eatnumber1-e5b3e12558e4a487b185e508933f94e61d92cc20.tar.bz2
eatnumber1-e5b3e12558e4a487b185e508933f94e61d92cc20.zip
Add pidgin-omegle
-rw-r--r--x11-plugins/pidgin-omegle/files/Makefile23
-rw-r--r--x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild33
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-omegle/files/Makefile b/x11-plugins/pidgin-omegle/files/Makefile
new file mode 100644
index 0000000..035cf3e
--- /dev/null
+++ b/x11-plugins/pidgin-omegle/files/Makefile
@@ -0,0 +1,23 @@
+CC ?= gcc
+LD ?= ld
+CFLAGS += -fPIC
+
+CFLAGS += `pkg-config --cflags pidgin`
+CFLAGS += `pkg-config --cflags json-glib-1.0`
+LDFLAGS += `pkg-config --libs pidgin`
+LDFLAGS += `pkg-config --cflags json-glib-1.0`
+
+OBJECTS=libomegle.o om_connection.o
+
+.PHONY: all clean
+
+all: libomegle
+
+libomegle: $(OBJECTS)
+ $(LD) $(LDFLAGS) $(OBJECTS) -shared -soname $@.so -o $@.so
+
+.c.o:
+ $(CC) -c $(CFLAGS) $< -o $@
+
+clean:
+ $(RM) $(OBJECTS) libomegle.so
diff --git a/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild b/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild
new file mode 100644
index 0000000..1d9be66
--- /dev/null
+++ b/x11-plugins/pidgin-omegle/pidgin-omegle-scm.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+ESVN_REPO_URI="http://${PN}.googlecode.com/svn/trunk/"
+
+inherit subversion toolchain-funcs multilib
+
+DESCRIPTION="Omegle Plugin for Pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-omegle/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="net-im/pidgin
+ dev-libs/glib:2
+ dev-libs/json-glib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile .
+ tc-export CC LD
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/purple-2
+ insopts -m755
+ doins libomegle.so
+}